Вход | Регистрация
 

В отладчике почти все реквизиты объекта отображаются как null

В отладчике почти все реквизиты объекта отображаются как null
Я
   Nyarlathotep
 
08.10.18 - 10:20
Всем привет!

Столкнулся с такой очень странной проблемой...

Если в отладке нахожу объект по наименованию, как вот тут https://drive.google.com/file/d/1_LO101-rBb1fLQd1uuOtE3xnBkqEuLQm/view?usp=sharing, у найденого объекта почему-то почти все реквизиты отображаются как null (на скриншоте видно). Если же на форме смотрю Объект, как вот тут https://drive.google.com/file/d/1hNA82yec5C0jgmfXCwBPduT7ZWyBMtiz/view?usp=sharing, то все показывает нормально. Соответственно, если находя объект по наименованию, я его куда-то подставляю, например Номенклатуру из примера в тч Заказа клиента Товары в поле Номенклатура, то, когда я отладичком его там смотрю (в поле Номенклатура после записи Заказа), там тоже у него почти все поля оказыватся в null, соответственно база не читает занчения реквизитов и валится потом с ошибками. Никогда с таким не сталкивался... Платформа - 8.3.13.1513, конф. - ЕРП 2.4.5.33. Тестирование и исправление со всеми галками делал. Что это вообще такое? Что с этим делать?
 
 
   hhhh
 
1 - 08.10.18 - 10:24
(0) наверно группу нашел, а не элемент. В группе как раз все должны быть null.
   Nyarlathotep
 
2 - 08.10.18 - 10:54
(1) Хммм... Да, действиетльно группу нашел, у заказчика оказалась довольно совеобразная структура спр. Номенклатура... Ну спасибо всем.

Список тем форума
Рекламное место пустует  Рекламное место пустует
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.