Вход | Регистрация
 

Как не дать пользователю возможность выбрать элемент справочника в выпадающем меню?

Как не дать пользователю возможность выбрать элемент справочника в выпадающем меню?
Я
   gabd_marat
 
18.09.18 - 09:32
Как не дать пользователю возможность выбрать элемент справочника в выпадающем меню и при вводе в строку?
    Если ДокументОбъект.Метаданные().Имя = "ТребованиеНакладная" Тогда
        ЭлементОтбора = ФормаВыбора.СправочникСписок.Отбор.Найти("Код");
        Если ЭлементОтбора = Неопределено Тогда
            ЭлементОтбора = ФормаВыбора.СправочникСписок.Отбор.Добавить("Код");
        КонецЕсли;
        ЭлементОтбора.Установить("000000001");
        ФормаВыбора.ЭлементыФормы.СправочникСписок.НастройкаОтбора.Код.Доступность    = Ложь;
        ФормаВыбора.СправочникСписок.Отбор.Код.ВидСравнения                         = ВидСравнения.НеРавно;
    КонецЕсли;

    
    Если ТипЗнч(Склад) = Тип("СправочникСсылка.Склады") Тогда
        ФормаВыбора.НачальноеЗначениеВыбора = Склад;  
    КонецЕсли;
                  
    ФормаВыбора.Открыть();
 
 
   gabd_marat
 
1 - 18.09.18 - 09:32
Выбрать в поле документа
   gabd_marat
 
2 - 18.09.18 - 09:34
Первую часть вроде сделал, вторую как понимаю надо делать в обработчике приокончаниивводатекста
   gabd_marat
 
3 - 18.09.18 - 09:35
Может есть универсальный способ?
   butterbean
 
4 - 18.09.18 - 09:35
в модуле менеджера справочника поковыряй событие ОбработкаПолученияДанныхВыбора
   gabd_marat
 
5 - 18.09.18 - 10:00
(4) Она для не управляемых форм подойдет?
   butterbean
 
6 - 18.09.18 - 10:00
(5) без режим совместимости с 8.2 и ниже - подойдет
   butterbean
 
7 - 18.09.18 - 10:01
(6) хотя, может и на 8.2 сработает, не помню уже
   Сергиус
 
8 - 18.09.18 - 10:01
(0)Может проще рлс'ом на роль пользователя ограничить?
   gabd_marat
 
9 - 18.09.18 - 10:16
(7) есть пример?
   Eiffil123
 
10 - 18.09.18 - 10:31
Самое простое - в справочнике отключить ввод по строке. Тогда ни в каких полях системы ввод по строке для этого справочника не сработает.

Делается в редактировании справочника, закладка "Поле ввода".
   gabd_marat
 
11 - 18.09.18 - 11:09
(10) Без этого не получиться ? можно как то поставить условие на выпадающий список и приокончаниивводатекста убрать данный справочниксклады изи списка доступных?
   Cyberhawk
 
12 - 18.09.18 - 11:54
У поля есть свойство СписокВыбора
   Eiffil123
 
13 - 18.09.18 - 12:46
(11) ну так это нужно делать по всех формах, где этот справочник используется. Если это нужно только для одной формы, тогда у реквизита на форме отключить редактирование текста.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.