Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Значение не является значением объектного типа (ПолучитьОбласть)

Значение не является значением объектного типа (ПолучитьОбласть)
Я
   dft2014
 
09.06.18 - 18:27
При формировании отчета выходит ошибка:
Значение не является значением объектного типа (ПолучитьОбласть)

Подскажите, как это побороть? Ниже кусочек кода:


&НаСервере
Процедура ПросмотретьНаСервере()
    
    ТЗ = Новый ТаблицаЗначений;
    ТЗ.Колонки.Добавить("День");
    ТЗ.Колонки.Добавить("Месяц");
    
    ТекДат = НачалоДня(Отчет.Дата1);
    
    Пока ТекДат <= НачалоДня(Отчет.Дата2) Цикл
        НовСтр = ТЗ.Добавить();
        НовСтр.День = ТекДат;
        НовСтр.Месяц = Месяц(ТекДат);
        
        ТекДат = ТекДат+86400;
    КонецЦикла;
    
    НовТабДок = Новый ТабличныйДокумент;    
    Макет = Отчет.РеквизитМакет;
    
    Шапка = Макет.ПолучитьОбласть("Шапка");
    НовТабДок.Вывести(Шапка);
    
    Для Каждого СтрокаТЗ Из ТЗ Цикл
        СтрокаТЧ = Макет.ПолучитьОбласть("СтрокаТЧ");
        СтрокаТЧ.Параметры.День = ТЗ.День;
        НовТабДок.Вывести(СтрокаТЧ);
    КонецЦикла;
    
КонецПроцедуры
 
 
   mehfk
 
1 - 09.06.18 - 19:15
>> Подскажите, как это побороть?
Ты программист или как?
   dft2014
 
2 - 09.06.18 - 19:18
(1) начинается...
Да, я программистка
   hhhh
 
3 - 09.06.18 - 19:20
(0) вот это очень странное выражение
   Макет = Отчет.РеквизитМакет;

присмотритесь к нему. Похоже вы в Макет какую-то фигню грузите.
   mehfk
 
4 - 09.06.18 - 19:25
(2) Проверяй тип в отладчике Отчет.РеквизитМакет
   dft2014
 
5 - 11.06.18 - 19:24
(3), (4) Отчет.РеквизитМакет в отладчике Неопределенно почему-то?!
   dft2014
 
6 - 11.06.18 - 19:39
Разобралась! Надо было написать:

НовТабДок = Новый ТабличныйДокумент;
    Макет = РеквизитФормыВЗначение("Отчет").ПолучитьМакет("Макет");
    Шапка = Макет.ПолучитьОбласть("Шапка");
    НовТабДок.Вывести(Шапка);

Список тем форума
Рекламное место пустует  Рекламное место пустует
Проблемы невозможно решaть нa том же уровне компетентности, нa котором они возникaют. Альберт Эйнштейн
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.