Вход | Регистрация
 

Документооборот, ОбъектПочта = Новый <<?>>Почта; Тип не определен (Почта)

Документооборот, ОбъектПочта = Новый <<?>>Почта; Тип не определен (Почта)
Я
   spiller26
 
09.04.18 - 14:45
Документооборот КОРП 2.1.5.6
Платформа 8.3.10.2252

Общ.модуль "ЛегкаяПочтаКлиент" - галочка Клиент (упр.приложение)
При обращении к функции выдает ошибку.

{ОбщийМодуль.ЛегкаяПочтаКлиент.Модуль(186,22)}: Тип не определен (Почта)
ОбъектПочта = Новый <<?>>Почта;

Что не так ему?
 
 
   aka AMIGO
 
1 - 09.04.18 - 14:47
Рекомендаций по платформе в описании к конфигурации - нет?
   mehfk
 
2 - 09.04.18 - 14:50
(0) Ошибка выдается во время работы или сразу в конфигураторе при проверке синтаксиса?
   Вафель
 
3 - 09.04.18 - 14:53
может нужен сервер все-таки?
   spiller26
 
4 - 09.04.18 - 14:58
(2) В конфигураторе, скачал 2.1.9.3 таже ошибка
   spiller26
 
5 - 09.04.18 - 14:58
(3) Почта (Mail)
Методы:
Выбрать (Get)
Отключиться (Logoff)
Подключиться (Logon)
Послать (Send)
Конструкторы:
По умолчанию
Описание:
Предназначен для доступа к почтовой системе, установленной на компьютере. Используется технология MAPI.
Доступность:
Тонкий клиент, толстый клиент.
Пример:
Почта = Новый Почта;
   Ц_У
 
6 - 09.04.18 - 15:01
вызов покажи
   spiller26
 
7 - 09.04.18 - 15:03
(6) вызов чего? функции?
   spiller26
 
8 - 09.04.18 - 15:05
&НаКлиенте
Процедура ОбновитьСписокСообщений(Команда = Неопределено)
    
    Если Не ЗначениеЗаполнено(ПараметрыЗагрузкиПочтовыхСообщений.НастройкиПрофилейДляЗагрузки.Профиль) Тогда
        ПоказатьПредупреждение(, НСтр("ru = 'Не выбран почтовый профиль!'"));
        Возврат;
    КонецЕсли;
    
    Состояние(НСтр("ru = 'Идет загрузка электронной почты. Пожалуйста, подождите...'"));
    
    ЭтаФорма.Заголовок = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
        НСтр("ru = 'Загрузка электронной почты (%1)'"),
        Профиль);
        
    ОписаниеОповещения = Новый ОписаниеОповещения(
        "ОбновитьСписокСообщенийПродолжение",
        ЭтотОбъект);
    ЛегкаяПочтаКлиент.Получить(ПараметрыЗагрузкиПочтовыхСообщений, ОписаниеОповещения);
    
КонецПроцедуры
   spiller26
 
9 - 09.04.18 - 15:09
Создал внешнюю обработку, кидаю кнопку.

&НаКлиенте
Процедура Команда1(Команда)
    ОбъектПочта = Новый Почта;
КонецПроцедуры

Проверка в конфигураторе:

{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(4,22)}: Тип не определен (Почта)
    ОбъектПочта = Новый <<?>>Почта; (Проверка: Тонкий клиент)
   mehfk
 
10 - 09.04.18 - 15:10
(9) Попробуй на другой платформе.
 
 Рекламное место пустует
   YaFedor
 
11 - 09.04.18 - 15:11
Предназначен для доступа к почтовой системе, установленной на компьютере - что это значит?

Доступ к почтовому клиенту, установленному по умолчанию? А если его нет?
   oslokot
 
12 - 09.04.18 - 15:12
(10) повангуй лучше
   spiller26
 
13 - 09.04.18 - 15:13
Эта версия конфигурации "1С:Документооборот КОРП" предназначена для
использования с версией платформы "1С:Предприятие", начиная с 8.3.8.2197.
   spiller26
 
16 - 09.04.18 - 15:16
(11) Короче переписывать, т.к. мы на Линухе все сидим.
   mehfk
 
17 - 09.04.18 - 15:17
(13) Может именно 8.3.10.2252 бажная. На пустой конфе на 8.3.10.2561 создал внешнюю обработку с кодом как в (9) - ошибок нет.


Список тем форума
Рекламное место пустует  Рекламное место пустует
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует