Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Вывод заголовка полей СКД

Вывод заголовка полей СКД
Я
   Franchiser
 
05.04.18 - 12:46
Есть поле которое выведено одновременно на уровне группировки отчета СКД и на уровне детальных записей. Как сделать, чтобы в заголовке не дублировалось название поля в 2х строках?
 
 
   aleks_default
 
1 - 05.04.18 - 14:45
Убери это поле из детальных записей, раз уж оно есть в группировке
   Franchiser
 
2 - 06.04.18 - 12:37
Сделал так по аналогии с найденным в сети:
// Проверка двух смежных ячеек на идентичночность

Функция ОбъединятьЯчейки(ТабДок, индСтр, индКол)

 Ячейка = ТабДок.Область(индСтр, индКол);
 ЯчейкаСлед = ТабДок.Область(индСтр+1, индКол);
 Если ПустаяСтрока(Ячейка.Текст) Тогда

 Возврат ложь

 ИначеЕсли
//Проверяем на соответствие заголовка

 Ячейка.Текст = ЯчейкаСлед.Текст
        // Проверяем на соответствие имени (отсеиваем уже объединенные ячейки)

//и Ячейка.Имя = "R"+индСтр+"C"+индКол 

 Тогда

 Возврат Истина;

 Иначе

 Возврат ложь

 КонецЕсли;

КонецФункции

// Обработка заголовков таблицы

//
// Параметры

// Табл - < Тип.ТабличныйДокумент> - Табличный документ формы
Процедура ОбработатьЗаголовки(ТабДок)

 ОбъединяемаяОбласть = Неопределено;

//Для оптимизации здесь нужно будет ограничить высоту таблицы

 Для индКол=1 По ТабДок.ШиринаТаблицы Цикл
     
     НачальнаяСтрока = 0;
     Для индСтр=1 По 8 Цикл
        // определяем начало объединения

         Если ОбъединятьЯчейки(ТабДок, индСтр, индКол) Тогда
             
             Если не НачальнаяСтрока Тогда
                 
                // НачальнаяКолонка = индКол;

                 
                 НачальнаяСтрока = индСтр;
                 
                 
             КонецЕсли;
             
         ИначеЕсли НачальнаяСтрока Тогда
            // завершаем объединение

             
             ТекстЗаголовка = ТабДок.Область(индСтр, индКол).Текст;
            //ОбъединяемаяОбласть = ТабДок.Область(индСтр, НачальнаяКолонка, индСтр, индКол);

             ОбъединяемаяОбласть = ТабДок.Область(НачальнаяСтрока, индКол, индСтр, индКол);  //SAV

             
             ОбъединяемаяОбласть.Объединить();
             ОбъединяемаяОбласть.ГоризонтальноеПоложение = ГоризонтальноеПоложение.Центр;
             ОбъединяемаяОбласть.Текст = ТекстЗаголовка;
            // НачальнаяКолонка = 0;

             НачальнаяСтрока=0;
             
             
         Иначе
             
            //НачальнаяКолонка = 0;

             НачальнаяСтрока=0;
             
         КонецЕсли;
         
     КонецЦикла;
    
     
 КонецЦикла;

КонецПроцедуры
   Franchiser
 
3 - 06.04.18 - 12:44
помогла статья:
http://catalog.mista.ru/public/77916/
   Franchiser
 
4 - 06.04.18 - 12:48
(1) есть 1 группировка состоящая из 4-х полей, и далее детальные записи из 10 полей. Если сделать автополе (т.е. не использовать поля из группировок), тогда выглядит некрасиво.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Компьютер — устройство разработанное для ускорения и автоматизации человеческих ошибок.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует