Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Подключить терминал сбербанка к тис 7.7. Есть вопросы

v7: Подключить терминал сбербанка к тис 7.7. Есть вопросы
Я
   tgu82
 
27.12.17 - 16:59
Всех с Наступающим Новым Годом!
ТИС 7.7
Терминал сбербанка vx820
Все установлено. Библиотеки зарегистрированы
Есть описание для 1С 7.7 файл 1С.docx от 29.05.2017

Процедура ПриОткрытии()

ПутьДоКомпоненты = "C:\SC552\SBRFCOM.DLL";
Если ЗагрузитьВнешнююКомпоненту(ПутьДоКомпоненты)=1 Тогда
    //Внешняя компонента загружена
Иначе
    Сообщить("Внешняя компонента SBRFCOM.DLL не загружена!!!");
КонецЕсли;

КонецПроцедуры    //ПриОткрытии()

Процедура Оплата()
    Терм = СоздатьОбъект("AddIn.SBRFCOMExtension");
    рез  = Терм.ОплатитьПлатежнойКартой(Amount, RRN, AuthCode, Hash, IsOwn, CardName, CardNum);
ОписКО = "";    // Описание кода ошибки
    Если рез=1 Тогда
        Слип = "";        // Строка со слипом.
        буф  = "";        // Буфер для текущей строки слипа.
        Для НомерСтр=1 По Терм.КоличествоСтрокСлипЧека Цикл
            Терм.ПолучитьСтрокуСлипЧека(НомерСтр, буф);
            Слип = Слип + буф;
            Если НомерСтр>1 Тогда
                Слип = Слип + Симв(10) + Симв(13);
            КонецЕсли;
        КонецЦикла;
Сообщить(Слип);
    Иначе
        Сообщить("Ошибка оплаты:" + Терм.ПолучитьОшибку(ОписКО));
    КонецЕсли;
Терм = 0;
КонецПроцедуры    //Оплата()

Вроде как мне нужна только amount - сумма в копейках, для чего мне остальные параметры ведь номер карты терминал же сам определяет.
RRN, AuthCode, Hash, IsOwn, CardName, CardNum - они мне нужны или это не для карт сбера а скажем для карт на АЗС?

Терминал проверен, связь есть, пробные пробития делал и отменял через
loadparm

Но с 1С пока как-то стремно завязывать. Пока что даже не про фискальник речь а просто про методы и свойства самой библиотеки sbrfcom.dll
 
 
   tgu82
 
1 - 27.12.17 - 18:12
(0) Там просто есть библиотека на 7 параметров и на 3 - я так понимаю что мне надо на три параметра. Но какие это должны быть три параметра - непонятно. Наверное Номер карты,сумма и вид карты ? Подскажите пожалуйста
   tgu82
 
2 - 27.12.17 - 19:41
(0) Разобрался
ОплатитьПлатежнойКартой имеет всего 3 параметра: Сумма, КодRRN и КодАвторизации.
   mgk2
 
3 - 27.12.17 - 23:15
А с драйвером платёжных систем не удобней работать?
   Злопчинский
 
4 - 28.12.17 - 00:37
(3) вот ит из?
   Boudybuilder
 
5 - 28.12.17 - 00:40
Очень интересно, почему в 2017 году пользуются 7.7?
Связано с  сложным переносом данных на 8.3?
   Злопчинский
 
6 - 28.12.17 - 00:46
(5) у меня есть клиент: ЦБ и точек штук 12 - просим к столу для аудита и переноса
   Злопчинский
 
7 - 28.12.17 - 00:46
Недорого
Качественно
И быстро
;-)
   Boudybuilder
 
8 - 28.12.17 - 01:28
(6) Ну так я поэтому и пишу :) Ну а есть товарищи которым плевать на прошлое, и начинают жизнь с нового листа? С новой базой и вводом начальных остатков? Хотя если база с интеграциями разными, то и тут не легко решиться.
   tgu82
 
9 - 28.12.17 - 08:19
(3) КодRRN и КодАвторизации. Вот эти параметры должны вводиться откуда-то?
   tgu82
 
10 - 28.12.17 - 08:25
(8) Все За. Вот только то надо дописать в 8-ку, потом это надо и т.д.
   mgk2
 
11 - 28.12.17 - 10:17
   big
 
12 - 28.12.17 - 10:20
(4) Это атоловский драйвер. Но он платный.
(8) Новая база, новое железо, новые танцы по функционалу и быстродействию. В итоге - 2-3 млн.руб. вложений, год траханья и нервов, а на выходе то же самое, но красивее  )))

Владельцы бизнеса в полном ***уе  )))
   mgk2
 
13 - 28.12.17 - 10:20
   Kigo_Kigo
 
14 - 28.12.17 - 14:11
так понимаю, что тебе надо передать только сумму платежи, КодРНН и код авторизации к тебе вернуться, что хочешь что и делай, хочешь игнорируй, хочешь в док для иформации пиши
ПыСы, Длл-ками по 820 не поделитесь?
   УспешныйЧел
 
15 - 28.12.17 - 14:15
(5) работают люди и работают, вам то какое дело? И зачем что-то куда то переносить?
   tgu82
 
16 - 29.12.17 - 13:36
(15) Затем что даже в уриб в 7.7 много нерешаемых штатным путем проблем и еще много зачемю Но сложно все на самом деле
   tgu82
 
17 - 29.12.17 - 13:37
(0) Что касается темы ветки то все вроде нормально функционирует но пока еще не пробовали по РДП

Список тем форума
Рекламное место пустует  Рекламное место пустует
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.