Вход | Регистрация
 

Как записать роль через COM соединение ?

Как записать роль через COM соединение ?
Я
   Олеся999
 
01.12.17 - 08:31
Подскажите пожалуйста как записать роль через COM соединение ?

ВнСоед =  ПодключитьсяКБазеНазначения(); //Соединяемся по COM
НовыйПользователь = ВнСоед.ПользователиИнформационнойБазы.СоздатьПользователя();
НовыйПользователь.Имя =  "Пользователь1";
НовыйПользователь.Записать();

//Тут все отлично создает пользователя !
//Но как добавить роль ?
//Если делать так то все хорошо, роль добавляется
НовыйПользователь.Роли.Добавить(ВнСоед.Метаданные.Роли.Админ);
//А как вот сделать что бы можно было  : ВнСоед.Метаданные.Роли.<подставлять переменную> ???

//Пробовала так но не прокатывает (((
Для Каждого СтрР из ВнСоед.Метаданные.Роли Цикл
     ДобР = тз_роли.Добавить();
    ДобР.РолиС= СтрР; //ComОбъект
    ДобР.РолиН= СтрР.name; //Имя строковый тип
КонецЦикла;    
Для Каждого СтрР из тз_роли Цикл
    Если  "Админ" = СтрР.РолиН     Тогда
НовыйПользователь.Роли.Добавить(СтрР.РолиС);
КонецЕсли;
КонецЦикла;
 
 
   FIXXXL
 
1 - 01.12.17 - 08:41
ВнСоед.Метаданные.Роли[ПеременнаяТипСтрока]
   _stay true_
 
2 - 01.12.17 - 08:47
(1) ВнСоед.Метаданные.Роли[ПеременнаяТипСтрока] - солидарен.
   Олеся999
 
3 - 01.12.17 - 09:10
Спасибо получилось :)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует