Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

1C УФ, передача массива "ВыделенныеСтроки" с клиента на сервер

1C УФ, передача массива "ВыделенныеСтроки" с клиента на сервер
Я
   kiabs
 
14.11.17 - 10:40
Приветствую. Слом голову уже, почему постоянно  вываливается ошибка "Поле объекта недоступно для записи"

На клиенте:

ЗагрузитьДокументНаСервере(ЭтаФорма.Элементы.НайденныеДокументы.ВыделенныеСтроки);

где НайденныеДокументы - реквизит формы с типом Таблица значений.

На сервере просто запускаю цикл по массиву.

Для каждого ИндексСтроки Из МассивВыбранных Цикл  
КонецЦикла;      
    
И при возвращении на клиент падает с ошибкой:

Поле объекта недоступно для записи (ВыделенныеСтроки)
    ЗагрузитьДокументНаСервере(ЭтаФорма.Элементы.НайденныеДокументы.ВыделенныеСтроки);

Что делаю не так?
   kiabs
 
1 - 14.11.17 - 10:42
Процедура на сервере выглядит вот так 
&НаСервере
Процедура ЗагрузитьДокументНаСервере(МассивВыбранных)//МассивВыбранных - массив индексов выделенных строк

        
Для каждого ИндексСтроки Из МассивВыбранных Цикл  
КонецЦикла;          
             
        
КонецПроцедуры
   DrShad
 
2 - 14.11.17 - 10:43
Процедура ЗагрузитьДокументНаСервере(ЗНАЧ МассивВыбранных)
   kiabs
 
3 - 14.11.17 - 10:50
(2) Спасибо добрый человек. Не знал про ЗНАЧ, теперь буду использовать. ТЫ сделал меня чуть чуть умнее.

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.