Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Помогите с вводом на основании

Помогите с вводом на основании
Я
   Радим1987
 
26.09.17 - 07:54
День добрый.КА УФ. Добавил два документа. Один документ вводится на основание другого. Добавил все процедуры БСП

[1c]
// Заполняет список команд создания на основании.
//
// Параметры:
//   КомандыСоздатьНаОсновании - ТаблицаЗначений - состав полей см. в функции ВводНаОсновании.СоздатьКоллекциюКомандСоздатьНаОсновании
//
// Возвращаемое значение:
//     КомандыСоздатьНаОсновании - ТаблицаЗначений - состав полей см. в функции ВводНаОсновании.СоздатьКоллекциюКомандСоздатьНаОсновании
//
Функция ДобавитьКомандуСоздатьНаОснованииПланаПроизводства(КомандыСоздатьНаОсновании) Экспорт

    
    Если ПравоДоступа("Добавление", Метаданные.Документы.РТ_КорректировкаПланаПроизводства) Тогда
        КомандаСоздатьНаОсновании = КомандыСоздатьНаОсновании.Добавить();
        КомандаСоздатьНаОсновании.Идентификатор = Метаданные.Документы.РТ_КорректировкаПланаПроизводства.ПолноеИмя();
        КомандаСоздатьНаОсновании.Представление = ВводНаОсновании.ПредставлениеОбъекта(Метаданные.Документы.РТ_КорректировкаПланаПроизводства);
        КомандаСоздатьНаОсновании.ПроверкаПроведенияПередСозданиемНаОсновании = Истина;    
        Возврат КомандаСоздатьНаОсновании;
    КонецЕсли;

    Возврат Неопределено;
КонецФункции


// Заполняет список команд создания на основании.
//
// Параметры:
//   КомандыСоздатьНаОсновании - ТаблицаЗначений - состав полей см. в функции ВводНаОсновании.СоздатьКоллекциюКомандСоздатьНаОсновании
//
Процедура ДобавитьКомандыСозданияНаОсновании(КомандыСоздатьНаОсновании) Экспорт  
    
    Документы.РТ_КорректировкаПланаПроизводства.ДобавитьКомандуСоздатьНаОснованииПланаПроизводства(КомандыСоздатьНаОсновании);
            
КонецПроцедуры

        // ВводНаОсновании
    ВводНаОсновании.ПриСозданииНаСервере(ЭтотОбъект, Элементы.ПодменюСоздатьНаОсновании);
    // Конец ВводНаОсновании

[/1c]

Но почему то никак не попадаю в процедуру обработкаЗаполнения просто открывается форма
 
 
   Адинэснег
 
1 - 26.09.17 - 09:19
ДокОбъект.Заполнить()
   Радим1987
 
2 - 26.09.17 - 09:45
Исправил. Невнимательность. На форме документа основной реквизит другой был

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует