Вход | Регистрация
 

Серверные вызовы при завершении работы, вот это все...

Серверные вызовы при завершении работы, вот это все...
Я
   H A D G E H O G s
 
10.09.17 - 00:55
Ночи доброй.

Запилил обход этого новшества, на примере УТ11.2, #спасибоНашему1С
Может кому-то пригодится.

Процедура АСФПодключаемый_ПередЗавершениемРаботыСистемы() Экспорт
    Отказ=Ложь;
    // СтандартныеПодсистемы
    СтандартныеПодсистемыКлиент.ПередЗавершениемРаботыСистемы(Отказ);
    // Конец СтандартныеПодсистемы
    
    // ПодключаемоеОборудование
    МенеджерОборудованияКлиент.ПередЗавершениемРаботыСистемы();
    // Конец ПодключаемоеОборудование
    //АСФ
    Окна=ПолучитьОкна();
    МассивОсобыхФорм=Новый Массив;
    МассивОсобыхФорм.Добавить("Обработка.ТекущиеДела.Форма.Форма");
    Для Каждого ТекущееОкно Из Окна Цикл
        Для Каждого ТекущаяФорма Из ТекущееОкно.Содержимое Цикл
            Если МассивОсобыхФорм.Найти(ТекущаяФорма.ИмяФормы)<>Неопределено Тогда
                Попытка
                    ТекущаяФорма.АСФВыполнитьПередЗакрытием();
                Исключение
                КонецПопытки;
            Иначе
                ТекущаяФорма.Закрыть();
            КонецЕсли;
        КонецЦикла;
    КонецЦикла;
    АСФСерверныеВызовыЗапрещены=Истина;
    АСФСтруктураСОбъектамиРасширения=Неопределено;
    ЗавершитьРаботуСистемы(Ложь);
    //АСФ
    
КонецПроцедуры

Процедура ПередЗавершениемРаботыСистемы(Отказ)
    Если АСФСерверныеВызовыЗапрещены=Истина Тогда
        Возврат;
    КонецЕсли;
    
    Отказ=Истина;
    ПодключитьОбработчикОжидания("АСФПодключаемый_ПередЗавершениемРаботыСистемы",0.1,Истина);
    ОбъектРасширения=АСФРасширенияФункционала.ПолучитьОбъектРасширения();
    ОбъектРасширения.ЗакрытьВопрос();
    Возврат;
......
КонецПроцедуры

ОбъектРасширения.ЗакрытьВопрос() запускает отдельный поток, который ждет это прекрасное окно с вопросом пользователю и нажимает "Продолжить работу" мягко, не нарушая сна.

Я готов к режиму совместимости 8.3.10, а ты?
   H A D G E H O G s
 
1 - 12.09.17 - 17:02
Сегодня ушло в продакшн.
Вроде все пока неплохо - единственное - был затык с ПравоДоступа() в одной внешней обработки.
   H A D G E H O G s
 
2 - 12.09.17 - 17:03
Ну и всякие комментарии сжались - в нескольких местах убирал галку Автоширина у элементов управления. Ничего критичного.
   Fragster
 
3 - 12.09.17 - 17:15
нужно больше костылей
   Fragster
 
4 - 12.09.17 - 17:15
ну и да - все равно в браузере не работает
   Fragster
 
5 - 12.09.17 - 17:16
кстати, в БСП убрали некоторые функции в  ДополнительнгыеВнешниеОбработкиВБезопасномРежиме (или как-то общий модуль называется)
   H A D G E H O G s
 
6 - 17.09.17 - 19:53
Еще немного вылезло - в режиме 8.3.10, в запросах запрещено объединять поля разных типов, одним из которых является строка неограниченной длины.

Это вылезло в типовых отчетах, куда в СКД, параметрами передаются значения колонок в виде строковых констант, например
АнализДоходовИРасходов, колонка СтатьяРасходов. В СКД, на вкладке Параметры, у параметра "СтрокаСебестоимостьПродажПредварительная" нужно задать длину строки, например в 50 символов

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.