Вход | Регистрация
 

После обновления платформы на 8.3.10.2252 печатает одну страницу на двух

После обновления платформы на 8.3.10.2252 печатает одну страницу на двух
Я
   RomaH
 
25.05.17 - 09:39
В предпросмотре таб док отображается на одной странице
а при печати протягивает вторую (чистая)

Печатаем на бланках больничных - порча оных очень не желательна

Как выход - установить при печати - печать страницы 1

Из 1С это свойство можно установить?
 
 
   cw014
 
1 - 25.05.17 - 09:41
Колонтитулы, поля?
   RomaH
 
2 - 25.05.17 - 09:41
при этом один больничный печатается на одной странице
а другой на двух

это точно не принтер - потому-что один и тот же больничный - всегда печатается одинаково - либо на одной, либо на двух
   Fish
 
3 - 25.05.17 - 09:41
(0) А если табдок на 2-х и более страницах?
   RomaH
 
4 - 25.05.17 - 09:42
(1) и что - колонтитулов нет
поля по нулям
   shamannk
 
5 - 25.05.17 - 09:42
Продолжайте наблюдения)))
   polosov
 
6 - 25.05.17 - 09:42
(0) Да намутили они что-то в платформе.
Пользователи БП и УТ жалуются на проблемы масштабирования ПФ.
   Fish
 
7 - 25.05.17 - 09:43
"Как выход - установить при печати - печать страницы 1 " - А вообще, это гениально. Вместо того, чтобы разобраться в проблеме и устранить её, сделать костыль :))
   RomaH
 
8 - 25.05.17 - 09:43
(3) пока других аномалий не замечено
эта печатная - она сама по себе "странная"
поля - нулевые 
бумага - не стандартная

но до обновления платформы проблем не было
   cw014
 
9 - 25.05.17 - 09:43
(2) Как вариант - какая то строка не умещается в одну строку и переносится - макет "разъезжается"
   Fish
 
10 - 25.05.17 - 09:44
(8) Как вариант, откатитесь на предыдущую. Чем была вызвана необходимость обновляться именно на эту платформу?
   RomaH
 
11 - 25.05.17 - 09:44
(7) в этом случае надо сначала устранить проблему
а потом решать её
   shamannk
 
12 - 25.05.17 - 09:44
(8) Ни одного разрыва?
   polosov
 
13 - 25.05.17 - 09:45
(11) Откатись на 8.3.9
   RomaH
 
14 - 25.05.17 - 09:45
(10) мне не нужна психологическая помощь
я спрашиваю как победить конкретно такой глюк
   Fish
 
15 - 25.05.17 - 09:46
(14) Если это глюк платформы, то только откатом на предыдущую.
   cw014
 
16 - 25.05.17 - 09:48
(14) см в (9)
   RomaH
 
17 - 25.05.17 - 09:51
т.е. вариант указать программно принтеру печатать только первую страницу - не вариант? ну или принтер настроить так?
   RomaH
 
18 - 25.05.17 - 10:14
еще странность
кроме новой платформы - еще и БСП новая

используется подсистема печати

так вот - при печатити из подсистемы (по кнопке печать в ОФ "Печать документов" или "Печать сразу" 
печатает две страницы
если в той же форме - предпросмотр - печать - печатает одну страницу
   mikecool
 
19 - 25.05.17 - 10:18
(18) а еще - картинки перерисовали! ))
   RomaH
 
20 - 25.05.17 - 10:30
воспроизводится при печати в принтер который "OneNote"
   Вафель
 
21 - 25.05.17 - 10:41
автомасштаб надеюсь отключен?
   Вафель
 
22 - 25.05.17 - 10:41
для таких штук нельзя на авто полагаться
   Вафель
 
23 - 25.05.17 - 10:42
и все строки должны быть фикс высоты конечно же
   Antony8x
 
24 - 25.05.17 - 10:46
(0) в параметрах страницы попробуйте Масштаб установить "По ширине страницы"
   RomaH
 
25 - 25.05.17 - 11:01
(24) нельзя
больничный видел
мне надо в клетки при печати попадать
   Fish
 
26 - 25.05.17 - 11:03
(25) А принтер обычный или специальный для точной печати?
   Antony8x
 
27 - 25.05.17 - 11:04
(25) ясно. дерзай тогда
   Вафель
 
28 - 25.05.17 - 11:05
(26) ну количество листов вроде не принтер определяет.
Хотя может и он, но я не видел когда бы ошибался
   RomaH
 
29 - 25.05.17 - 11:05
о - зацепка
в БСП теперь же не табличный документ печатается
а пакет, , отображаемых документов
   Fish
 
30 - 25.05.17 - 11:05
(26) У нас помнится, для печати на бланках ПТС специально покупали такой: http://www.epson.ru/catalog/matrix/C11C560171/

Он гарантированно попадает в нужные клетки, даже если бумагу под углом в него запихнёшь.
 
 Рекламное место пустует
   RomaH
 
31 - 25.05.17 - 11:06
(26) в "OneNote" воспроизводится

путем дрочки макета выяснил - "не влезает" по ширине
   Fish
 
32 - 25.05.17 - 11:08
(31) Значит, надо в макете делать фиксированную ширину. Раз у тебя "разъезжаются" не все документы, то где-то ширина не фиксированная и меняется в зависимости от текста.
   RomaH
 
33 - 25.05.17 - 11:11
(32) там все сложно 
бланки больничных разного размера (иногда кривые)
поэтому сделана возможность подстройки - путем изменения ширины первой колонки макета....
тут только обрезать крайнюю правую колонку в макете - не выводить последние символы в некоторых графах
   RomaH
 
34 - 25.05.17 - 11:11
но я думаю замена пакета отображаемых обратно на табличный докуменьт исправит ситуацию
   RomaH
 
35 - 25.05.17 - 11:22
(34) нет - не исправит
   RomaH
 
36 - 25.05.17 - 11:23
придется обрадовать админа - еще раз платформу поменять
и записать в чек лист - печать больничных
   RomaH
 
37 - 25.05.17 - 12:01
еще прикол

в макете табличного стало нельзя выделить область с шифтом слева

справа вверх и вниз можно - а влево - нельзя
   Вафель
 
38 - 25.05.17 - 12:23
(33) ты через ЖПО все сделал просто
   ildary
 
39 - 25.05.17 - 12:49
(37) вы ошибки-то в 1С сообщайте, а то как они их исправят?
   RomaH
 
40 - 25.05.17 - 13:06
(39) да вот собрался ... да не выходит каменный цветок

им же надо "воспроизвести"
а не воспроизводится - копирую макет в обработку - и в обработке его с такими же настройками печати выводит на два листа
   RomaH
 
41 - 25.05.17 - 14:48
все-таки это БСП
Область печати не копирует в коллекцию для печати

т.е. на форме показывает весь таб док - допустим 100 колонок заполненных
но в макете - задана область печати в 98 колонок

системные функции работают с таб доком который на форме - там область печати есть 
а по кнопке "Печать" - собирается новая коллекция из ТабДок = Новый ТабличныйДокумент

с копированием свойств - ну про область печати забыли
   RomaH
 
42 - 25.05.17 - 15:17
подскажите - что не так:
вроде область печати назначается
но печатает все-равно весь документ

&НаСервере
Функция ТабличныеДокументыДляПечати()
    ТабличныеДокументы = Новый СписокЗначений;
    
    Для Каждого НастройкаПечатнойФормы Из НастройкиПечатныхФорм Цикл
        Если Элементы[НастройкаПечатнойФормы.ИмяРеквизита].Вывод = ИспользованиеВывода.Разрешить И НастройкаПечатнойФормы.Печатать Тогда
            ПечатнаяФорма = ЭтотОбъект[НастройкаПечатнойФормы.ИмяРеквизита];
            ТабличныйДокумент = Новый ТабличныйДокумент;
            ТабличныйДокумент.Вывести(ПечатнаяФорма);
            ЗаполнитьЗначенияСвойств(ТабличныйДокумент, ПечатнаяФорма, УправлениеПечатью.КопируемыеСвойстваТабличногоДокумента());
            
            //Лобанов

            ТабличныйДокумент.ОбластьПечати = ТабличныйДокумент.Область(ПечатнаяФорма.ОбластьПечати.Верх,ПечатнаяФорма.ОбластьПечати.Лево,ПечатнаяФорма.ОбластьПечати.Низ,ПечатнаяФорма.ОбластьПечати.Право);
            //Лобанов

            
            ТабличныйДокумент.КоличествоЭкземпляров = НастройкаПечатнойФормы.Количество;
            ТабличныеДокументы.Добавить(ТабличныйДокумент, НастройкаПечатнойФормы.Представление);
        КонецЕсли;
    КонецЦикла;
    
    Возврат ТабличныеДокументы;
КонецФункции
   Вафель
 
43 - 25.05.17 - 15:19
какая конфа и версия БСП?
   Вафель
 
44 - 25.05.17 - 15:19
(42) на форму и на печать разные документы идут. Там еще раз копирование
   cw014
 
45 - 25.05.17 - 15:24
Вот вопрос про 8.3.10. У тебя есть справочник "Банковские счета"?
   RomaH
 
46 - 25.05.17 - 15:25
они издеваются
потом из этой коллекции формируется уже пакет документов путем еще одного "копирования"

все всем спасибо
   RomaH
 
47 - 25.05.17 - 15:25
(43) последняя
   cw014
 
48 - 25.05.17 - 15:26
(46) У тебя есть справочник из (45)
   RomaH
 
49 - 25.05.17 - 15:26
// Формирует пакет документов для отправки на принтер.

Функция ПакетДокументов(ТабличныеДокументы, ОбъектыПечати, ПечататьКомплектами, КоличествоЭкземпляров = 1) Экспорт
    
    ПакетОтображаемыхДокументов = Новый ПакетОтображаемыхДокументов;
    ПакетОтображаемыхДокументов.РазборПоКопиям = Истина;
    КоллекцияПечатныхФорм = ТабличныеДокументы.ВыгрузитьЗначения();
    
    Для Каждого ПечатнаяФорма Из КоллекцияПечатныхФорм Цикл
        ПечататьКомплектами = ПечататьКомплектами Или ПечатнаяФорма.ДвусторонняяПечать <> ТипДвустороннейПечати.Нет;
    КонецЦикла;
    
    Если ПечататьКомплектами И ОбъектыПечати.Количество() > 0 Тогда 
        Для Каждого ОбъектПечати Из ОбъектыПечати Цикл
            ИмяОбласти = ОбъектПечати.Представление;
            Для Каждого ПечатнаяФорма Из КоллекцияПечатныхФорм Цикл
                Область = ПечатнаяФорма.Области.Найти(ИмяОбласти);
                Если Область = Неопределено Тогда
                    Продолжить;
                КонецЕсли;
                
                ТабличныйДокумент = ПечатнаяФорма.ПолучитьОбласть(Область.Верх, , Область.Низ);
                ЗаполнитьЗначенияСвойств(ТабличныйДокумент, ПечатнаяФорма, КопируемыеСвойстваТабличногоДокумента());//Вот  тут еще раз область печати забыли

                
                ПакетОтображаемыхДокументов.Состав.Добавить().Данные = ПакетСОднимТабличнымДокументом(ТабличныйДокумент);
            КонецЦикла;
        КонецЦикла;
    Иначе
   RomaH
 
50 - 25.05.17 - 15:27
(45) а что там? - вроде есть БанковскиеСчетаОрганизаций
   cw014
 
51 - 25.05.17 - 15:27
(50) Есть какой нибудь справочник с составным типом, например с составным владельцем?
   RomaH
 
52 - 25.05.17 - 15:29
зачем?
   RomaH
 
53 - 25.05.17 - 15:29
у меня много чего есть
   cw014
 
54 - 25.05.17 - 15:30
(53) Мне бы запрос примерно такой:

ВЫБРАТЬ РАЗЛИЧНЫЕ ТипЗначение(Владелец) ИЗ Справочник.БанковскиеСчета

На составном поле выполнить и проверить, работает или нет
   Вафель
 
55 - 25.05.17 - 15:31
(0) А как у тебя раньше то вообще работало?
   RomaH
 
56 - 25.05.17 - 23:23
(54) а что мешает?


Список тем форума
Рекламное место пустует  Рекламное место пустует
Читай всё полезное и впитывай, а нападки игнорируй. Здесь так принято. aka AMIGO
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.