Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как как присвоить значение реквизиту и вывести на форму (управ формы)

Как как присвоить значение реквизиту и вывести на форму (управ формы)
Я
   ЯСтараюсь
 
26.10.16 - 10:38
Добрый день.

В документе есть 2 реквизита
ФИО (Строка) и РегистрируемоеЛицо (справочникСсылка)
и в форме объекта они же
Нужно при записи документа, значение введенное в реквизите ФИО преобразовалось в объект справочника и выводилось на форме.

Все получается, кроме вывода на форму.

Подскажите ПЛИЗ как это сделать.

код:
На форме:

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)

   ДокументОбъект = РеквизитФормыВЗначение("Объект");
   ДокументОбъект.ДобавитьПроживающего(ТекущийОбъект.ФИО);
   ЗначениеВРеквизитФормы(ДокументОбъект, "Объект");
        
   Сообщить(Объект.РегистрируемоеЛицо);
КонецПроцедуры;

в модуле объекта:

Функция  ДобавитьПроживающего(ФИО) экспорт

            СпрПрож = Справочники.бит_Проживающие.НайтиПоНаименованию(ФИО, Истина);
            Если СпрПрож.Ссылка.Пустая() Тогда
                ...........
                (создает новый)    
            КонецЕсли;
            
            РегистрируемоеЛицо   = СпрПрож.Ссылка;

КонецФункции
 
 
   Lexey_
 
1 - 26.10.16 - 10:48
(0) Объект.РегистрируемоеЛицо   = СпрПрож.Ссылка;
   ЯСтараюсь
 
2 - 26.10.16 - 10:56
(1)
Объект.РегистрируемоеЛицо - не дает.
Поробовал так:
ЭтотОбъект.РегистрируемоеЛицо = СпрПрож.Ссылка;

Не помогло(
   Lexey_
 
3 - 26.10.16 - 10:57
(2) "Объект.РегистрируемоеЛицо - не дает"
дает
   ЯСтараюсь
 
4 - 26.10.16 - 11:00
(3)
В модуле объекта - не дает.
в модули формы - дает

я выполняю в модуле объекта
   Рэйв
 
5 - 26.10.16 - 11:02
(4)У тебя же функция. Вот и возвращай на форму ссылку, а там заполняй. Модуль объкта как то не очень в курсе что у тебя еще и форма открыта
   ЯСтараюсь
 
6 - 26.10.16 - 11:05
(5)
я потом заметил про функцию и поправил на Процедуру.
   Рэйв
 
7 - 26.10.16 - 11:07
(6)А теперь поправь обратно и возвращай на форму.
   ЯСтараюсь
 
8 - 26.10.16 - 13:23
(7)
получилось спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
Проблемы невозможно решaть нa том же уровне компетентности, нa котором они возникaют. Альберт Эйнштейн
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.