Вход | Регистрация
 

Неужели ошибка. не могу установит субконто.

Неужели ошибка. не могу установит субконто.
Я
   jadvali
 
04.10.16 - 16:57
на ОСВ нету отчета
и на результата проводки(Кт Дт)
что делать помогите пж.



Док = Документы.ПриходныйКассовыйОрдер.СоздатьДокумент();
                        Док.Дата=Дата(датаД-1)// ДобавитьМесяц(датаД,-1);

                        Док.УстановитьНовыйНомер();
                        Док.ВидОперации=Перечисления.ВидыОперацийПКО.ОплатаПокупателя;
                        Док.ВалютаДокумента=Справочники.Валюты.НайтиПоНаименованию("руб.");    
                        Док.СуммаДокумента=сумма;
                        Док.Ответственный = Справочники.Пользователи.НайтиПоНаименованию(СокрЛП("fffffffffffffffff"));
                        Док.Организация=Справочники.Организации.НайтиПоНаименованию("ffffffffff");
                        Док.Контрагент=Справочники.Контрагенты.НайтиПоНаименованию(контрагент);
                        Док.СчетКасса=ПланыСчетов.Хозрасчетный.НайтиПоКоду("50.01");
                        Док.Комментарий="Пред "+Строка(сумма)+"-АС";
                        //Док.СубконтоКт1 =Справочники.Контрагенты.НайтиПоНаименованию(контрагент);

                        //Док.СубконтоКт2 =Справочники.ДоговорыКонтрагентов.НайтиПоНаименованию("Основной договор");

                        //Док.СубконтоКт2 = Док.ЭтотОбъект;                        

                    
                        СтрРКО = Док.РасшифровкаПлатежа.Добавить();
                        СтрРКО.ДоговорКонтрагента=Справочники.ДоговорыКонтрагентов.НайтиПоНаименованию("Основной договор");
                        СтрРКО.СпособПогашенияЗадолженности=Перечисления.СпособыПогашенияЗадолженности.Автоматически;
                        СтрРКО.СтавкаНДС=Перечисления.СтавкиНДС.БезНДС;
                        СтрРКО.СуммаПлатежа=сумма;
                        СтрРКО.СтатьяДвиженияДенежныхСредств=Справочники.СтатьиДвиженияДенежныхСредств.НайтиПоНаименованию("Оплата товаров, работ, услуг, сырья и иных оборотных активов");
                        СтрРКО.СчетУчетаРасчетовПоАвансам=ПланыСчетов.Хозрасчетный.НайтиПоКоду("62.02");
                        СтрРКО.СчетУчетаРасчетовСКонтрагентом=ПланыСчетов.Хозрасчетный.НайтиПоКоду("62.01");
                        
                            Док.Записать(РежимЗаписиДокумента.Проведение);
                    
                            НаборЗаписей = РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей();
                             НаборЗаписей.Отбор.Регистратор.Установить(Док.Ссылка);
                
                             НаборЗаписей.Прочитать();

                            //Если НаборЗаписей.Количество() = 0 Тогда

                            // ;

                            //КонецЕсли;

                            // переберем все записи набора и заполним суммы по налоговому учету

                             Для каждого Запись из НаборЗаписей Цикл
                              // перед изменением сумм проверяем ведется ли налоговый учет на выбранном счёте

                              Если Запись.СчетДт.НалоговыйУчет Тогда
                               Запись.СуммаНУДт = Запись.Сумма;
                              КонецЕсли;
                              Если Запись.СчетКт.НалоговыйУчет Тогда
                               Запись.СуммаНУКт = Запись.Сумма;
                                 КонецЕсли;
                                                            
                              //НаборЗаписей = СтруктураШапкиДокумента.Ссылка.СубконтоКт1;

                              //Запись.СубконтоКт[1]=ПолеВвода2;

                              //БухгалтерскийУчет.УстановитьСубконто(Запись.СчетКт,Запись.СубконтоКт,1,ПолеВвода2);

                              БухгалтерскийУчет.УстановитьСубконто(Запись.СчетДт,Запись.ПодразделениеДт,1,ПланыСчетов.Хозрасчетный.НайтиПоКоду("50.01"));
                              БухгалтерскийУчет.УстановитьСубконто(Запись.СчетДт,Запись.СубконтоДт,1,Справочники.СтатьиДвиженияДенежныхСредств.НайтиПоНаименованию("Оплата товаров, работ, услуг, сырья и иных оборотных активов"));

                              БухгалтерскийУчет.УстановитьСубконто(Запись.СчетКт,Запись.ПодразделениеКт,1,ПланыСчетов.Хозрасчетный.НайтиПоКоду("62.02"));
                              БухгалтерскийУчет.УстановитьСубконто(Запись.СчетКт,Запись.СубконтоКт,1,Справочники.Контрагенты.НайтиПоНаименованию(контрагент));
                              БухгалтерскийУчет.УстановитьСубконто(Запись.СчетКт,Запись.СубконтоКт,2,Справочники.ДоговорыКонтрагентов.НайтиПоНаименованию("Основной договор"));
                              БухгалтерскийУчет.УстановитьСубконто(Запись.СчетКт,Запись.СубконтоКт,3,"Приходный кассовый ордер "+Док.Номер+" от "+Док.Дата);
                              //БухгалтерскийУчет.УстановитьСубконто(Запись.СчетКт,Запись.СубконтоКт,3,Док.Ссылка);

    

                          КонецЦикла;
                            //установим признак обмена данными    

                             НаборЗаписей.ОбменДанными.Загрузка = Истина;
                             НаборЗаписей.Записать();
   Господин ПЖ
 
1 - 04.10.16 - 16:58
чем помочь то? эвтаназия у нас запрещена
   shuhard
 
2 - 04.10.16 - 17:02
(0)[Неужели ошибка.] Да
[что делать] учиться
   Ёпрст
 
3 - 04.10.16 - 17:03
(0)
>>> СтрРКО.ДоговорКонтрагента=Справочники.ДоговорыКонтрагентов.НайтиПоНаименованию("Основной договор");

Это пять!


ЗЫ: весь код в топку.
   Ёпрст
 
4 - 04.10.16 - 17:04
И..если Приходник и так проводится, зачем еще потом набор движений отдельно перебирать ?
   Ёпрст
 
5 - 04.10.16 - 17:05
Ты это, разберись с основными реквизитами дока и оно того, само проведётся как надо и в осв появится.
   jadvali
 
6 - 04.10.16 - 17:06
ну нас есть услуга такая непростая.
на услугу мы получаем ну скажем так какое то процент.
каждую каплю денег бухгалтер приходовать на 1с как "Оплата товаров, работ, услуг, сырья и иных оборотных активов" и я хотел всё это каплю денег автоматом входил на 1с из нашего базы(mysql). Я написал код для этого

Док = Документы.ПриходныйКассовыйОрдер.СоздатьДокумент();
                        Док.Дата=Дата(датаД-// ДобавитьМесяц(датаД,-1);



                        Док.УстановитьНовыйНомер();
                        Док.ВидОперации=Перечисления.ВидыОперацийПКО.ОплатаПокупателя;
                        Док.ВалютаДокумента=Справочники.Валюты.НайтиПоНаименованию("руб.");    
                        Док.СуммаДокумента=сумма;
                        Док.Ответственный = Справочники.Пользователи.НайтиПоНаименованию(СокрЛП("fffffffffffffffff"));
                        Док.Организация=Справочники.Организации.НайтиПоНаименованию("ffffffffff");
                        Док.Контрагент=Справочники.Контрагенты.НайтиПоНаименованию(контрагент);
                        Док.СчетКасса=ПланыСчетов.Хозрасчетный.НайтиПоКоду("50.01");
                        Док.Комментарий="Пред "+Строка(сумма)+"-АС";
                        //Док.СубконтоКт1 =Справочники.Контрагенты.НайтиПоНаименованию(контрагент);



                        //Док.СубконтоКт2 =Справочники.ДоговорыКонтрагентов.НайтиПоНаименованию("Основной договор");



                        //Док.СубконтоКт2 = Док.ЭтотОбъект;                        



                    
                        СтрРКО = Док.РасшифровкаПлатежа.Добавить();
                        СтрРКО.ДоговорКонтрагента=Справочники.ДоговорыКонтрагентов.НайтиПоНаименованию("Основной договор");
                        СтрРКО.СпособПогашенияЗадолженности=Перечисления.СпособыПогашенияЗадолженности.Автоматически;
                        СтрРКО.СтавкаНДС=Перечисления.СтавкиНДС.БезНДС;
                        СтрРКО.СуммаПлатежа=сумма;
                        СтрРКО.СтатьяДвиженияДенежныхСредств=Справочники.СтатьиДвиженияДенежныхСредств.НайтиПоНаименованию("Оплата товаров, работ, услуг, сырья и иных оборотных активов");
                        СтрРКО.СчетУчетаРасчетовПоАвансам=ПланыСчетов.Хозрасчетный.НайтиПоКоду("62.02");
                        СтрРКО.СчетУчетаРасчетовСКонтрагентом=ПланыСчетов.Хозрасчетный.НайтиПоКоду("62.01");
                        
                            Док.Записать(РежимЗаписиДокумента.Проведение);

это код создают ПКО как в ручном виде но на ОСВ нету сумма
   jadvali
 
7 - 04.10.16 - 17:07
(6) потом хотел установит субконто вот субконто не получается
   Ёпрст
 
8 - 04.10.16 - 17:12
(6) вот когда ты пишешь, например, это:
 СтрРКО.ДоговорКонтрагента=Справочники.ДоговорыКонтрагентов.НайтиПоНаименованию("Основной договор");


договор какого клиентоса, по-твоему найдёт ?
   jadvali
 
9 - 04.10.16 - 17:13
(8) да
   Ёпрст
 
10 - 04.10.16 - 17:14
(9) что да ?
   Господин ПЖ
 
11 - 04.10.16 - 17:14
а что приборы?
   jadvali
 
12 - 04.10.16 - 17:16
(10) есть идея?
   Ёпрст
 
13 - 04.10.16 - 17:17
(12) Скушай сникерс - включи мозг!
   hhhh
 
14 - 04.10.16 - 17:27
(12) вот это объясни
                           БухгалтерскийУчет.УстановитьСубконто(Запись.СчетКт,Запись.ПодразделениеКт,1,ПланыСчетов.Хозрасчетный.НайтиПоКоду("62.02"));
   
подразделение это же не субконто.
и почему в подразделение ты счет пихаешь?
   jadvali
 
15 - 04.10.16 - 17:27
(13) ну ты тоже не знаешь да что делать.
   Mauser
 
16 - 04.10.16 - 17:28
(15) Гасконец, как ваше имя?
   del123
 
17 - 04.10.16 - 17:29
по моему это бот какой то))
   jadvali
 
18 - 04.10.16 - 17:29
(16) Аслон Ботирович
   Ёпрст
 
19 - 04.10.16 - 17:30
(15) Что же делать ? Надо что-то делать

ЗЫ: наверное, нужно подставлять хотя бы основной договор конкретного  клиентоса, с нужным видом договора, а не искать его среди хреновой тучи всех договоров всех клиентосов по наименованию.
   jadvali
 
20 - 04.10.16 - 17:38
(19) ну вот это уже результат
   jadvali
 
21 - 04.10.16 - 17:38
(19) как искать договоров по наименованию??????????
   Ёпрст
 
22 - 04.10.16 - 17:40
(21) Зачем?
   hhhh
 
23 - 04.10.16 - 17:45
(20) не все реквизиты занес, поэтому

                      СтрРКО.СуммаВзаиморасчетов=сумма;

потом Курс где у тебя? Кратность?

без курса не будет осв.
   jadvali
 
24 - 04.10.16 - 17:50
(23) hhhh - а можно ссылку или правильною направлению для созданий правильный ПКО такого рода.
   hhhh
 
25 - 04.10.16 - 17:53
(24) все реквизиты надо заполнить. а не только некоторые
   jadvali
 
26 - 08.10.16 - 09:57
(25) Spasibo HHHH poluchilos.


Список тем форума
 
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.