Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Установить курсор на нужную строку в ТЧ обработки (УФ)

Установить курсор на нужную строку в ТЧ обработки (УФ)
Я
   mua thu
 
05.09.16 - 11:50
Добрый день!
Пожалуйста подскажите: в обработке есть 2 ТЧ. 1-я Контрагенты и 2-я ДанныеПоКонтрагентам. Идея такая: при перемещении курсором по первой ТЧ во второй изменяется состав ТЧ в зависимости от выбранного контрагента. Это реализовано. При первом заполнении таблиц в 1-й курсор (удачно) ставлю на первую строку: Элементы.Контрагенты.ТекущаяСтрока = 0;

Необходимо при перемещении курсора по 1-й ТЧ контролировать правильность введенных данных во 2- ТЧ и если не все данные введены - переходить например на первую строку ТЧ. Пытаюсь реализовать это в событии 1-й ТЧ - ПриАктивизацииСтроки(Элемент)  
Если НЕ Проверка Тогда
Элементы.Контрагенты.ТекущаяСтрока = 0;
КонецЕсли;

Вроде отрабатывает код, но курсор переходит на следующую строку а не на ту которую требуется.

Заранее благодарю!
 
 
   oslokot
 
1 - 05.09.16 - 11:51
ТекущаяСтрока это не просто число
   mua thu
 
2 - 05.09.16 - 11:57
(1) Вроде просто номер строки,  т.е. число. При первом заполнении ТЧ курсор устанавливается правильно)
   oslokot
 
3 - 05.09.16 - 12:02
(2) это не номер строки
   oslokot
 
4 - 05.09.16 - 12:07
кури идентификатор строки
   mua thu
 
5 - 05.09.16 - 12:07
(3) Я не против, но прошу подсказки) Делаю так - тоже не помогает: Элементы.Контрагенты.ТекущаяСтрока = Объект.Контрагенты[0].ПолучитьИдентификатор();
   mua thu
 
6 - 05.09.16 - 12:10
Думаю дело в событии ПриАктивизацииСтроки, но как добиться желаемого пока не знаю) Получается типа я перехожу на новую строку - выполняется это событие и внутри него не получается установить курсор на произвольную строку.
   mua thu
 
7 - 05.09.16 - 12:12
Прощу прощения если у кого вызываю раздражение глупым вопросом, но правда не пойму пока как это сделать)
   Buster007
 
8 - 05.09.16 - 12:14
Если НЕ Проверка Тогда 
Элементы.Контрагенты.ТекущаяСтрока = 0;
КонецЕсли;
вот сюда, вместо нуля, тебе надо написать идентификатор строки, которая была до переключения.
   mua thu
 
9 - 05.09.16 - 12:29
(8) То есть если я хочу ставить курсор на первую строку то этот код по идее должен отрабатывать, но не активируется первая строка:
Если НЕ Проверка Тогда
Элементы.Контрагенты.ТекущаяСтрока = Объект.Контрагенты[0].ПолучитьИдентификатор();
КонецЕсли;
   FIXXXL
 
10 - 05.09.16 - 12:32
(9) вставь проверку на случай, если ты уже там где надо

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.