Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Запрет проведения документов задним числом

v7: Запрет проведения документов задним числом
Я
   uuee76
 
02.09.16 - 07:59
Коллеги,не являясь спецом по 7.7 и по ТиС,прошу помочь в решении проблемки.
Заказчик просит запретить изменять и проводить документы задним числом всем,кроме ну скажем с правами Администратора.
Есть дата запрета,вроде подходит,но каждый день заказчику невозможно ее менять.Можно запретить править проведенные доки,и снять право отмены проведения,но есть непроведенные доки,которые можно править когда угодно любым числом и проводить.Как можно вывернуться типовым функционалом?Вариант послать уже обдумал.Дописывать в каждый документ условие проведения?Ето корежить всю конфу.Автоматом менять дату запрета?А как,при каком условии?Если было оперативное проведение,как в 8,но такого механизма вроде нет...
   zak555
 
1 - 02.09.16 - 08:01
Пусть меняет дату запрета робот
   uuee76
 
2 - 02.09.16 - 08:06
(1) А как этого робота включить?Есть что-то,что запускается по расписанию автоматом?Где искать?Не знаю 7-ку,пните в правильном направлении.Администратор тем не менее тоже не может работать в закрытом периоде.Может без даты можно как то вывернуться?
   zak555
 
3 - 02.09.16 - 08:08
(2) выделяем пользователя робота, атгоритм пишем в глобальнике, запускаем с помощью планировшика через пакетный режим
   uuee76
 
4 - 02.09.16 - 08:13
(3) Понял куда рыть.Может еще мнения будут?
   zak555
 
5 - 02.09.16 - 08:18
(4) перейти на 8ку
Там можно выставить дату запрета, как вчерашний день
   uuee76
 
6 - 02.09.16 - 08:22
(5) Ну просто замечательный вариант!))Он мне тоже нравится.
   Это_mike
 
7 - 02.09.16 - 08:27
(5) а что мешает сделать так же в клюшках?
   Это_mike
 
8 - 02.09.16 - 08:30
Если ДатаДок<ТекущаяДата() Тогда
 Сообщить("нефик нафик!");
 статусВозврата(0);
 Возврат;
КонецЕсли;
   Это_mike
 
9 - 02.09.16 - 08:31
ну и опционально чонить типа:
 Если Константа.ДатаЗапретаРедактироваия < ТекущаяДата()-1 тогда
 Константа.ДатаЗапретаРедактироваия=ТекущаяДата()-1;
конецесли;
   Это_mike
 
10 - 02.09.16 - 08:32
только это все-таки не "заднее число", а вчерашнее.
заднее число - это уже утренний документ днем. Или документ 5-минутной давности...
   Тихий омут
 
11 - 02.09.16 - 08:32
Не нужен никакой робот. В ПриНачалеРаботыСистемы пишем что-то вроде
Константа.ДатаЗапретаРедактирования=ТекущаяДата()-1

Исполняется при входе любого пользователя, и всё.
Ну и проверки при открытии документов, само собой
   zak555
 
12 - 02.09.16 - 08:32
(8) это в какую процедуру?
   Тихий омут
 
13 - 02.09.16 - 08:33
(10) это уже детали
   zak555
 
14 - 02.09.16 - 08:33
(11) пользователь не выходит из базы ночью
   Это_mike
 
15 - 02.09.16 - 08:33
(12) в обработку проведения, вестимо.
или в глобальнике что-то типа глМожноПроводитьДокумент() есть
   Это_mike
 
16 - 02.09.16 - 08:35
(14) дык (9) в любой контроль записи/проведения
   Тихий омут
 
17 - 02.09.16 - 08:35
(11)+ проверка в модуле формы доков примерно такая,в процедуре ПриОткрытии():
Если ДатаДок<=Константа.ДатаЗапретаРедактирования Тогда ТолькоПросмотр(1) КонецЕсли
и усё
   zak555
 
18 - 02.09.16 - 08:35
(15) т.е. изменить документы можно, а провести нельзя?
   uuee76
 
19 - 02.09.16 - 08:36
(11) Это понятно,а вот без константы никак нельзя вывернуться?Нетрадиционными способами)))?Суть задачи не дать возможность изменить данные не сегодняшние)).
   Тихий омут
 
20 - 02.09.16 - 08:36
(14) ни разу не видел таких высоконагруженных систем, в которых безвылазно сидят пользователи и в течении суток ни один не зайдёт заново.
   Это_mike
 
21 - 02.09.16 - 08:38
(18) ну, в глМожноРедактироватьДокумент() вставить.
Не суть важно. сказали жк человеку, куда копать...
   Тихий омут
 
22 - 02.09.16 - 08:38
(19) гм... от всех дураков защиту не поставишь. Например, особенно умные пользюки могут и дату компа поменять, чтобы сделать вид, что сегодня-ещё вчера, а то и раньше. Вот тут как раз робот на серваке актуален, спору нет
   Это_mike
 
23 - 02.09.16 - 08:38
(19) см (8)
   zak555
 
24 - 02.09.16 - 08:38
(20) когда много пользователей, то они обычно в терминале
и закрывают терминал "крестиком" рдп -- вот тебе и повисший сеанс
   Это_mike
 
25 - 02.09.16 - 08:39
(24) авотхрен.
   _stay true_
 
26 - 02.09.16 - 08:39
Есть в семерке подписки на события?)))
   Это_mike
 
27 - 02.09.16 - 08:39
(22) получать с сервера, если база сиквельная :-)
   Это_mike
 
28 - 02.09.16 - 08:39
(26) в правильной семерке - есть
   Тихий омут
 
29 - 02.09.16 - 08:40
(19) Собственно, ответ на вопрос - в процедуре ПриОткрытии модуля формы дока пишем любую нужную проверку типа
Если ДатаДок<=НекоеЗначениеДатыЗапрета Тогда ТолькоПросмотр(1) КонецЕсли
здесь НекоеЗначениеДатыЗапрета - что угодно, пусть даже получение точного времени откуда-нибудь из инета
   Это_mike
 
30 - 02.09.16 - 08:42
(20) у кого работают высоконагруженные системы - такие вопросы не задают :-)
 
 
   uuee76
 
31 - 02.09.16 - 08:43
(29) Товарищи,база не скульная,люди могут не выходить ночью,утром продолжать работать.
   Тихий омут
 
32 - 02.09.16 - 08:45
(19) И кстати, если форма дока ну очень сильно переписанная, например, стандартная ТЧ заменена тз на форме, то ТолькоПросмотр(1) не пойдёт, там всё намного хитрее может оказаться.
(31) И что, за сутки прям реально ни один пользюк не зайдёт в базу, все сидят и сидят? Не верю. Ну даже если так - стучись из ПриОткрытии к поставщикам точного времени в инет, что тут тебе ещё сказать.
   Это_mike
 
33 - 02.09.16 - 08:46
(31) см. (8)+(9)+(15)
   Это_mike
 
34 - 02.09.16 - 08:49
(32) Можно получать через WSH с сервера.
   Смотрящий
 
35 - 02.09.16 - 08:58
(0) тАК ПРАВАМИ и разруливается - галка "Проведение документов задним числом"

Только заблокировать надо проведение документов будущей датой. Иначе ТА уедет "в завтра" и документы от сегодня система будет блокировать на редактирование - придется всех выгонять и откатывать ТА
   varelchik
 
36 - 02.09.16 - 11:55
(25)+100!
   varelchik
 
37 - 02.09.16 - 11:55
пардон (35)


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.