Вход | Регистрация
 

Будьте осторожны! обновление при помощи обновлятора БП 3.0.44.94

Будьте осторожны!  обновление при помощи обновлятора БП 3.0.44.94
Я
   g00d
 
26.08.16 - 09:44
У меня несколько клиентов обновилось с помощью автообновлятора и теперь не могут работать.

{ОбщийМодуль.СтандартныеПодсистемыСервер.Модуль(1101)}: Недопустимое обращение к необновленным параметрам работы программы
(например, к некоторым параметрам сеанса).

Необходимо перенести вызов прикладного кода
после обновления параметров работы программы.
                    НСтр("ru = 'Недопустимое обращение к необновленным параметрам работы программы
   vermazar
 
1 - 26.08.16 - 09:44
Удалить *.cdx
   Зая Бусечка
 
2 - 26.08.16 - 09:47
(1) Что удалить? Откуда в 8ке cdx?
   g00d
 
3 - 26.08.16 - 09:51
где удалять cdx на серверной базе? :)
   zak555
 
4 - 26.08.16 - 10:06
(0) зачем тебе обновлятор ?
нужно обновляться штатно
   hitodom
 
5 - 26.08.16 - 10:09
(4) а разница?
   zak555
 
6 - 26.08.16 - 10:10
(5) сейчас я штатно обновлюсь с 43
   hitodom
 
7 - 26.08.16 - 10:11
(6) У меня работает - у всех должно работать (с)
   zak555
 
8 - 26.08.16 - 10:14
3.0.43.124 -> 3.0.44.94
   zak555
 
9 - 26.08.16 - 10:14
(0) на какой платформе обновление проводилось ?
   g00d
 
10 - 26.08.16 - 10:18
8.3.6.1652
   g00d
 
11 - 26.08.16 - 10:18
3.0.43.263 - 3.0.44.94
   zak555
 
12 - 26.08.16 - 10:21
(10) так надо 8.3.8.2054
   g00d
 
13 - 26.08.16 - 10:22
Если это требование, почему она позволила обновиться?
   hitodom
 
14 - 26.08.16 - 10:26
(12) Это же тестовая. Почему тогда не 8.3.9?
   zak555
 
15 - 26.08.16 - 10:28
(14) а вот-вот будет релизом
а вот 8.3.9 ещё не скоро
   saaken
 
16 - 26.08.16 - 10:46
(13)
Звонок на фирму франчази, которая занимается допиливанием УПП:
- Нам нужно добавить небольшую функциональность в РТУ!
- Это стоит $150/час. Но для вас будет лучше,
если вы прочтете ЖКК и выполните эту работу сами.
Клиент, удивленный такой откровенностью спрашивает:
- А ваш босс знает, что вы таким образом препятствуете бизнесу?
- На самом деле, это его идея. Мы получаем куда больше прибыли, когда
позволяем нашим клиентам сначала самим попытаться что-то дописать.
   zak555
 
17 - 26.08.16 - 11:16
+ (8) как я и говорил:
никаких проблем в обновлении не было в клиент-сервером варианте, значит проблема в кривых руках
   hitodom
 
18 - 26.08.16 - 11:23
(17) так уже выяснили, что проблема в платформе.
   hitodom
 
19 - 26.08.16 - 11:23
кстати автору обновлятора можно на этом сыграть
   zak555
 
20 - 26.08.16 - 11:25
(18) проблема лишь в боязни ставить АКТУАЛЬНЫЙ релиз
   vermazar
 
21 - 26.08.16 - 12:32
(16) Пересказ известного анекдота.
   g00d
 
22 - 26.08.16 - 12:41
(20) причем тут боязнь?
что бы установить новую версию сервера, придется заранее обновить тонкие клиенты у около 60 пользователей находящихся в разных городах, в разных сетях.
Это реально трудоемко
   g00d
 
23 - 26.08.16 - 12:42
(17) в правильных обновлениях перед обновлением проверяется совместимость релиза с текущей платформой
   g00d
 
24 - 26.08.16 - 13:10
пользуясь случаем обращаюсь к автору автообновлятора!
Программа проверяет совместимость платформы и обновления?
   zak555
 
25 - 26.08.16 - 13:15
(22) админов нет, которые автоматизировали этот процесс ?
   g00d
 
26 - 26.08.16 - 13:17
(25) как себе представляешь процесс автоматизации обновления на компьютерах разных предприятий в разных городах. К которым даже не всегда есть администраторские права?
   Cyberhawk
 
27 - 26.08.16 - 13:17
Не понял, о каком автообновляторе речь?
   Cyberhawk
 
28 - 26.08.16 - 13:18
(26) Домен
   zak555
 
29 - 26.08.16 - 13:18
   zak555
 
30 - 26.08.16 - 13:19
(26) так пусть работают через вэб-клиент тогда, кто не обновил тонкий
 
 Рекламное место пустует
   Fish
 
31 - 26.08.16 - 13:22
Я так и не понял, это косяк обновлятора или при штатном обновлении то же самое?
   zak555
 
32 - 26.08.16 - 13:23
(31) при штатном не было
проверил на файловой и sql вариантах
   hhhh
 
33 - 26.08.16 - 13:24
(24) на самом деле может работать и на старой платформе. Там ведь не всё целиком. Что-то работает, что-то нет. Кто-то хочет оставаться на старой платформе несмотря на предупреждения. Поэтому автор автообновлятора стоит перед выбором.
   bazvan
 
 
34 - 26.08.16 - 13:25
Обсалютно о автообновлятор все обновил.
Просто некоторые тол. пы не читают реадми ТХТ прежде чем обновлять
   bazvan
 
 
35 - 26.08.16 - 13:26
(33) отключена совместимость с 8.3.6 так что на старых платформах я бы вообще не рекнул запускать
   hitodom
 
37 - 26.08.16 - 13:49
(20) расскажи нам как ты проводишь тестирование перед установкой новых релизов?
   hhhh
 
38 - 26.08.16 - 13:49
(34) он говорит, автообновлятор должен быть в курсе реадми, обновлять и платформу тоже.
   hitodom
 
39 - 26.08.16 - 13:50
(38) лучше пусть говорит, что платформа то у вас не та
   zak555
 
40 - 26.08.16 - 13:50
(37) зачем его тестировать, если он релиз
   Cyberhawk
 
41 - 26.08.16 - 13:50
(29) Так там обновлятор. А тут какой-то автообновлятор.
   bazvan
 
 
42 - 26.08.16 - 13:53
(39) а как это определить? Парсить реадми ТХТ или еще чего?
странные вы какие то.
Ну нет на текущий момент в платформе такого механизма.
И руками можно обновить, и не чего не скажет а потом ругатся будет.
Просили у 1сников что бы сделали проверку на совместимость но пока такого нет
   g00d
 
43 - 26.08.16 - 13:54
я говорю про то что обновлять не должен обновлять ИБ если версия платформы не совместима с обновлением.
   shuhard
 
44 - 26.08.16 - 13:56
(43) ты до сих пор веришь, что тебе кто-то должен ?
   g00d
 
45 - 26.08.16 - 13:56
(42) к тому же
базы после обновления были абсолютно не работоспособны. При старте сразу вываливаются в ошибку с перезапуском.
Но тем не менее обновлятор отчитался об успешном обновлении.
   g00d
 
46 - 26.08.16 - 13:57
(44) Конечно, я же заплатил этот продукт.
   zak555
 
47 - 26.08.16 - 13:59
(46) из кармана ?
   hhhh
 
48 - 26.08.16 - 13:59
(46) если заплатил, то ты должен обратиться к ним. Кому заплатил. Мы-то ничего не платили, у нас другие действия - сидеть и ждать пока 1с что-то придумает.
   hhhh
 
49 - 26.08.16 - 14:02
(42) раньше было другое. Например, написано, нужна такая-то версия платформы, но она нужна скажем для регламентной отчетности. А всё остальное некритично, работает на обеих платформах. Поэтому особенно не торопились с переходом, ждали более стабильных релизов.
   g00d
 
50 - 26.08.16 - 14:02
(47) именно из своего кармана
   zak555
 
51 - 26.08.16 - 14:07
(50) надо было посоветоваться с партнёром, который ИТС предоставляет
   Алексей Карманов
 
52 - 01.09.16 - 02:47
Друзья, всем привет. Я вышел из отпуска, ознакомился с проблемой и вот что я думаю:

1. Обновлятор уже сейчас проверяет  совметимость платформы и выдает соответствующее предупреждение в отчёт, когда у него есть возможность проверить эту версию.

У него есть возможность проверить эту версию, если это обновление было скачано обновлятором из интернета или у него есть доступ в интернет (стоит галка "Искать обновления на сайте 1С").

Парсить Readme.txt не проблема, но с ним может быть чехорда в том случае, если это отраслевая конфигурация, сделанная на основе типовой. Но я поставил в план парсить минимальную версию платформы оттуда, когда нет друго возможности узнать её.

2. Теперь вопрос, что мне делать зная, что наша текущая версия платформы не соответствует минимальной в требования 1с? В данный момент я ограничиваюсь предупреждением в отчёте  всё согласно таким аргументам:
- 1с очень рано начинает требовать обновление платформы для своих типовых и почти никто этого не делает сразу, очень рискованно, так как новые релизы зачастую сырые
- все проведенные мною до этого тесты показывали, что для тех случаев, когда обновление текущей версией платформы невозможно - платформа сама отказывалась применять это обновление или даже "зависала"

3. Исходя из описанного выше у меня в голове пока только такой план:
- добавить обработку readme.txt для тех случаев, когда не удалось получить минимальную версию платформы из других источников
- увеличить паузу после вывода в отчёт предупреждении о минимальной  версии (можно добавить это сообщение ещё в конце, но стоит ли - оно будет пугать пользователей, так как будет появляться в 80% случаев и вынуждать их тут же обновлять платформу, что не всегда хорошо)
- сделать в обновляторе опцию (значение по умолчанию НЕТ) - отказываться обновлять при несоответствии минимальной версии платформы
- отказываться обновлять вне зависимости от опций, если отличаются релизы текущей и требуемой платформы (например, 8.3.6 < 8.3.8).

Обсуждать лучше сюда: Всё еще обновляетесь вручную? Время бесценно, используйте обновлятор.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.