Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ERP Воссоздание управленческого учета

ERP Воссоздание управленческого учета
Я
   Mikhail Volkov
 
14.02.16 - 19:45
Основным поводом разделение учета на упр./регл. в лихие 90-е - это ведение взаиморасчетов в "у.е.", фактически в долларах, т.е. валютного. Позднее, когда рубль немного стабилизировался, и у кого большинство торговых операций на внутреннем рынке, стали в качестве упр. валюты использовать тоже рубль. При этом упр. учет стал полностью дублировать регламентный. Особо это не напрягало, в документах поступления есть курс взаиморасчетов, которым можно регулировать пересчет валютных сумм в рублевые. Но в ERP (УТ11) такой возможности не стало. Чтобы оплатить поставку валютой, ее сначала надо купить, т.е. конвертировать с рублевого счета на валютный. За конвертацию банк берет комиссионные, т.е. конвертирует не официальному курсу. А упр./регл. суммы взаиморасчетов, а затем себестоимость товара по оф. курсу, в основном заниженные. Что сильно напрягает пользователей, боятся продать товар ниже себестоимости. Просят исправить ситуацию, воссоздать упр. учет.
Более подробно ситуация изложена в Курсовые разницы в УТ11, но из-за неудачного ее названия, не отражающей сути проблемы, многие путаются.
Кто что думает по этому поводу, может есть у кого опыт по исправлению данной ситуации? Работа вроде объемная, не хотелось "бежать впереди поезда", в той теме промелькнуло о ERP 2.2.1 на подходе...
   Злопчинский
 
1 - 14.02.16 - 19:48
А ты поставь цену продажи = себестоимость*100 - перестанут бояться...
   Джинн
 
2 - 14.02.16 - 20:03
(0) Ваши выводы несостоятельные.

1. Основным поводом был черный нал, а не УЕ.

2. Упр. учет не стал дублировать регламентированный. Это разные виды учета. Отличные по оперативности, степени детализации и методикам отражения.

3. Пользователи пусть напрягаются не всякой хренью, а собственной бестолковостью. А также пусть напрягаются студентами, которые им спаривают всякую хрень.

4. По поводу исправления я применяю старое правило инженера - если техника не сломалась, то не фиг ее чинить.

5. Никакие ERP 1230.01 не будут автоматизировать всякую хрень. 1С применяет общепринятые методики и стандарты и старается в меру сил не изобретать велосипеды с квадратными колесами. Чаще успешно.
   shuhard
 
3 - 14.02.16 - 20:07
(0) мы думаем , что пользователи катастрофически ошиблись, доверив тебе автоматизация
   Джинн
 
4 - 14.02.16 - 20:09
Кстати цена продажи к себестоимости имеет мало отношения. Если на рынке аналогичный товар стоит, к примеру, 100 рублей, то за тысячу Вы его хрен продадите. И неважно какая у Вас при этом себестоимость.

Кроме того принцип "не ниже себестоимости" ущербный сам по себе. Кроме себестоимости у Вас есть коммерческие и общехозяйственные затраты. Не считая внереализационных. И их тоже нужно отбивать. Ориентируясь только на себестоимость Вы пролетите в трубу.

Есть и еще один нюанс - если Вы купили товар по 100 баксов и по курсу это было 7000 рублей, то такая себестоимость и будет по факту. Но продав его полностью ориентируясь на себестоимость, Вам нужно восполнить запасы и снова купить этот же товар. Но теперь Вам придется потратить на это 8000 рублей. Предприятия с такими управленцами умирают быстро.
   Garykom
 
5 - 14.02.16 - 20:38
(4) да у нас сейчас проблема что постоянно приходится делать переоценки ориентируясь на нынешние закупочные цены у поставщиков

а потом приходят клиенты/покупатели и говорят а мы вот такое вот в том другом магазине за стока купили, а вас типа в 2 раза оно дороже...
... но за скоко они купили мы сча у поставщиков закупаем, что сделать если у этих "конкурентов" маркетинг мышей не ловит?
   Cyberhawk
 
6 - 15.02.16 - 01:26
"Кто что думает по этому поводу, может есть у кого опыт по исправлению данной ситуации?" // Какой ситуации? В трех словах...
   Mikhail Volkov
 
7 - 15.02.16 - 05:40
(4) > Кроме себестоимости у Вас есть коммерческие и общехозяйственные затраты. Не считая внереализационных. И их тоже нужно отбивать. Ориентируясь только на себестоимость Вы пролетите в трубу.
Золотые слова - в этом и суть проблемы, наконец то до нее добрались!
В конце каждого месяца менеджеры крутят по себе "Анализ продаж и торговой наценки" (в Альфа-Авто), торговая наценка там считается как сумма продажи минус себестоимость. Потирают руки, ждут премию как % от сделанной ими наценки. А бухгалтерия свои отчеты выкрутила, и говорит: ребята, чего же вы ждете, вы же убытков наделали, внереализационные расходы не учли!?
Поэтому заказчику надо, чтобы упр. себестоимость включала в себя эти внереализационные расходы (а не "в космос уходят").
В теме Курсовые разницы в УТ11 только части внереализационных расходов касался.
(6) Теперь ясна ситуация?
   Cyberhawk
 
8 - 15.02.16 - 08:56
(7) Доп. расходы (транспортные) каким раком размазываете на товары?
   HeKrendel
 
9 - 15.02.16 - 09:32
(7) Для начала нужно понимать, что входит в себестоимость, у кого то прямые затраты это 80% себестоимости, у кого то  20. Поэтому сама себестоимость у этих компаний будет считаться по разному, и принятие решений будет по разному
   Масянька
 
10 - 15.02.16 - 09:39
(8) Не "раком", а согласно учету.
(7) Пусть бухи сядут, сведут среднемесячные расходы и выведут процент наценки. Хотя бы с этого начните.
   Cyberhawk
 
11 - 15.02.16 - 09:39
(10) Не понял
   Джинн
 
12 - 15.02.16 - 09:45
(7) Начало правильное. А вывод бредовый.
   Масянька
 
13 - 15.02.16 - 09:46
(11) Что ты не понял? При чем тут рак? Это у тебя нужно спросить.
   Джинн
 
14 - 15.02.16 - 09:47
(9) Не применяйте термин "прямые затраты". Тут о них речь не идет. Но в предыдущих сабжах неокрепшие умы путали их с себестоимостью. Это только все запутает.
   Джинн
 
15 - 15.02.16 - 09:55
(10) Бухи тут ни при чем. Это задача экономистов. То, что пытается запихать в незапихуемое автор, не учетная, а расчетная задача. Экономисты должны посчитать плановые объемы продаж, прогнозируемые затраты, определить долю коммерческих, общехозяйственных и прочих затрат. Можно по-правильному - на основании этого установить цены. Можно по-простому - дать менеджерам процент расходов, которые они должны накидывать. Я не беру тут еще стратегические цели - возможно боссы хотят оттяпать долю рынка и готовы по неким направлениям и в минус сработать. Или маркетологи готовы прогнуть цены под какую-то акцию.

Но диагноз автора совершенно очевиден - ларек.
   Масянька
 
16 - 15.02.16 - 09:58
(15) Ой, давайте не будем про "ларьки" тут пальцы гнуть.
   aka AMIGO
 
17 - 15.02.16 - 10:01
(10) 60% - традиционная цифирь.
Хватит и на ауди, и на съездить раз в год к пальмам, аборигенам, морю, обезьянам..
   Джинн
 
18 - 15.02.16 - 10:01
(16) Вы не правы. Ларек или транснациональная компания - это не пальцы или не пальцы. Это уровень менеджмента и организация бизнеса. Знаю несколько очень крупных компаний, которые тоже "ларьки".
   Джинн
 
19 - 15.02.16 - 10:04
(17) Директор одной из контор управлял по принципу:"Если продавать много и с большой наценкой, то денег должно хватить..." :) Пока рынок позволял. А потом жпо...
   eklmn
 
20 - 15.02.16 - 10:04
(18) ты обещался в субботней ветке по трезвости разнести всех в пух и прах :)
   Масянька
 
21 - 15.02.16 - 10:06
(17)
— У меня воз сена стоит десять рублей.
— Стоить-то оно стоит, да никто ж его не покупает. (С)
   Джинн
 
22 - 15.02.16 - 10:07
(20) Да я там уже по пьяни первую часть пояснил. А вторую уже поленился. Да и этот сабж логическое продолжение того - там коммерческие расходы запихивали в себестоимость, а тут внереализационные... Та же хрень.
   Mikhail Volkov
 
23 - 15.02.16 - 10:13
(12) В плане регламентного (БУ) согласен, а в плане упр. учета почему бредовая?
   ILM
 
24 - 15.02.16 - 10:20
(7) Go Goldratta читать! Там ваша проблема решена, что входит в себестоимость, а что нет.
   Cyberhawk
 
25 - 15.02.16 - 10:21
(13) Не понял назначение частицы "не" в (10)
   Господин ПЖ
 
26 - 15.02.16 - 10:21
(24) +1
хождения вокруг "Цели" Гордратта
   Джинн
 
27 - 15.02.16 - 10:28
(23) Потому что Вы валите методические ошибки клиента (и свои) на "управленческий учет". Считая что там "что хочу, то и ворочу". Чаще всего это изобретение велосипеда с квадратными колесами взамен имеющегося велосипеда с треугольными колесами. Оглянитесь вокруг - мир давно на круглых колесах.

Управленческий учет тоже должен следовать неким принципам и некой методологии. И желательно, чтобы различия с бухгалтерским были в оперативности, степени детализации, порядке отражения операций... Но не в базовых принципах, которые разрабатывались и шлифовались столетиями.

В сотый раз пишу - бухучет придумали не для отмазки перед налоговой, а для того, чтобы считать свои деньги.
   Масянька
 
28 - 15.02.16 - 10:46
(23) ИМХО, ты вместе с клиентом запутался...
Себестоимость - это себестоимость. А расходы (прямые, косвенные, управленческие и пр.) - это расходы. Расходы не всегда (!!!) ложатся на себестоимость. Но расходы нужно иметь ввиду при реализации. А поскольку расходы это не себестоимость, то учитывать расходы при реализации можно только наценкой.
Поэтому - бухи садятся (если нет экономистов) и считают расходы (которые не ложатся на с/с). И выводят процент наценки. И расходы учитываются отдельно (которые не попадают в с/с).
   Mikhail Volkov
 
29 - 15.02.16 - 19:12
(28) Во-во - бухгалтерия выдает де-факто, когда убытки уже сделаны, а "желательно, чтобы различия с бухгалтерским были в оперативности, степени детализации, порядке отражения операций..." (27)!
   Джинн
 
30 - 15.02.16 - 19:33
(29) Бухгалтерия занимается учетом уже свершившихся операций. Факт купли-продажи валюты у Вас тоже свершился. Какая религия запрещает отразить его в учете?

Не скатывайтесь на сферическое бла-бла-бла...
 
 
   xraf
 
31 - 15.02.16 - 19:59
(0) что реально нет в erp параллельного учета в уе? Ну кабзец
   xraf
 
32 - 15.02.16 - 20:04
Что-то все накинулись на топик-стартера за термин себестоимость. Он же не производством занимается, а продает купившее.
   Джинн
 
33 - 15.02.16 - 20:19
(32) У товара нет себестоимости?!
   Garykom
 
34 - 15.02.16 - 20:23
(33) ну может им бесплатно отдают, или даже приплачивают тогда эта "себестоимость" еще и прочие расходы покроет ))
   mikeA
 
35 - 15.02.16 - 20:25
(29) может вам финансового директора завести?
   Mikhail Volkov
 
36 - 24.02.16 - 12:36
(35) Финик есть, это его ТЗ - сделать в УТ11 нормальный оперативный учет (хотя бы как в 7-ке), а не повторение бухгалтерии (регламентного). Изменений в конфигурацию пришлось вносить, но их немного: их описание опубликовал на http://catalog.mista.ru/public/461389/ вместе с "Обработка документов по конвертации валюты".
   Сверчок
 
37 - 24.02.16 - 12:44
(36) "Финик есть, это его ТЗ".

Собственно, в этом всё: на форуме одинэсников кодер выведывает у публики чудеса средневекового негоцианства.

Ключевой вопрос к (0): тебе за исполнение работы финдиректора достойно приплатят?
   Alexor
 
38 - 24.02.16 - 12:48
(0) Что мешает относить конвертацию как допрасходы на поставку?
   Mikhail Volkov
 
39 - 24.02.16 - 13:04
(38) Изначально так и задумывалось, но курсовые разницы относятся к внереализационным расходам, поэтому по правилам БУ этого нельзя делать.
   Mikhail Volkov
 
40 - 24.02.16 - 15:50
(37) > за исполнение работы финдиректора
У нее своя работа, а моя работа - автоматизировать этот процесс
   Mikhail Volkov
 
41 - 27.02.16 - 08:11
Возникла проблема с предоплатой поставщикам, когда они есть, то надо, чтобы упр. сумма взаиморасчетов, рассчитывалась по курсу на день оплаты. В отчете движений по Регистр накопления "Расчеты с поставщиками по документам" эти суммы выводятся: Предоплата поставщику в валюте, Предоплата поставщику (упр.), Предоплата поставщику (регл.) причем по каждой оплате отдельно. Как бы мне их вытащить перед проведением Закупки по импорту?
   Mikhail Volkov
 
42 - 28.02.16 - 18:43
Похоже эти суммы формируются из движений самого документа "Поступление товаров и услуг" (не нашел?), а мне они нужны из документов оплаты. Написал свою функцию с учетом того, что предоплаты могут частичные, в несколько этапов, и с пере платой. Точнее, это предоплата уже за следующую поставку, но частично покрывает остаток не доплаты за 1-ю поставку. И еще, оплаты ведут по договорам, а документы забывают договор указывать!?

// По управленческому учету расчет взаиморасчетов с поставщиком по себестоимости предоплаты
//

Функция СебестоимостьПредоплаты(Документ) Экспорт
    
    КурсКонвертации = 0;
    Если Не Константы.УчитыватьКурсовыеРазницыСебестоимостьТоваровПоУправленческомуУчету.Получить()
     Или ТипЗнч(Документ) <> Тип("ДокументСсылка.ПоступлениеТоваровУслуг")
     Или Документ.Валюта = Константы.ВалютаУправленческогоУчета.Получить() Тогда
        Возврат КурсКонвертации;
    КонецЕсли;
    
    Запрос = Новый Запрос;
    Запрос.Текст = "
    |ВЫБРАТЬ РАЗРЕШЕННЫЕ
    |    РасчетыСПоставщикамиПоДокументам.ПредоплатаОстаток,
    |    РасчетыСПоставщикамиПоДокументам.ПредоплатаУпрОстаток,
    |    ВЫБОР
    |        КОГДА РасчетыСПоставщикамиПоДокументам.ПредоплатаОстаток = 0
    |            ТОГДА 0
    |        ИНАЧЕ РасчетыСПоставщикамиПоДокументам.ПредоплатаУпрОстаток / РасчетыСПоставщикамиПоДокументам.ПредоплатаОстаток
    |    КОНЕЦ КАК КурсКонвертации
    |ИЗ
    |    РегистрНакопления.РасчетыСПоставщикамиПоДокументам.Остатки(
    |            &Дата,
    |            ЗаказПоставщику = &ЗаказПоставщику
    |                ИЛИ ЗаказПоставщику = &Договор) КАК РасчетыСПоставщикамиПоДокументам
    |";
    
    Запрос.УстановитьПараметр("Дата",             Новый Граница(Документ.МоментВремени(), ВидГраницы.Исключая));
    Запрос.УстановитьПараметр("ЗаказПоставщику", ?(ЗначениеЗаполнено(Документ.ЗаказПоставщику), Документ.ЗаказПоставщику, Документ));
    Если ЗначениеЗаполнено(Документ.Договор) Тогда
        Запрос.УстановитьПараметр("Договор",    Документ.Договор);
    Иначе
        Запрос.Текст = СтрЗаменить(Запрос.Текст, "ЗаказПоставщику = &Договор", "АналитикаУчетаПоПартнерам.Контрагент = &Контрагент");
        Запрос.УстановитьПараметр("Контрагент", Документ.Контрагент);
    КонецЕсли;
        
    Выборка = Запрос.Выполнить().Выбрать();
    Если Выборка.Следующий() Тогда
        Если Выборка.ПредоплатаОстаток = Документ.СуммаДокумента Тогда
            КурсКонвертации = Выборка.КурсКонвертации;
        ИначеЕсли Выборка.ПредоплатаОстаток > 0 И Выборка.ПредоплатаОстаток < Документ.СуммаДокумента Тогда
            Коэффициенты = РаботаСКурсамивалютУТ.ПолучитьКоэффициентыПересчетаВалюты(Документ.Валюта, Документ.ВалютаВзаиморасчетов, Документ.Дата);
            КурсКонвертации = (Выборка.ПредоплатаУпрОстаток + (Документ.СуммаДокумента - Выборка.ПредоплатаОстаток) * Коэффициенты.КоэффициентПересчетаВВалютуУпр)/Документ.СуммаДокумента;
        ИначеЕсли Выборка.ПредоплатаОстаток > Документ.СуммаДокумента Тогда
            КурсКонвертации = СебестоимостьПредоплатыПревышающей(Документ, Выборка.ПредоплатаОстаток);
        КонецЕсли;
    КонецЕсли;
    Возврат КурсКонвертации;
    
КонецФункции

// Если остаток предоплаты превыщает сумму документа, то для расчета себестоимости предоплаты

// необходимо учитывать только предоплату по документу, без суммы ее превышающей
Функция СебестоимостьПредоплатыПревышающей(Документ, ПредоплатаПревышающая)
    
    Запрос = Новый Запрос;
    Запрос.Текст = "
    |ВЫБРАТЬ РАЗРЕШЕННЫЕ
    |    РасчетыСПоставщикамиПоДокументам.ПредоплатаПриход,
    |    РасчетыСПоставщикамиПоДокументам.ПредоплатаУпрПриход
    |ИЗ
    |    РегистрНакопления.РасчетыСПоставщикамиПоДокументам.Обороты(
    |            ,
    |            &Дата,
    |            ,
    |            ЗаказПоставщику = &ЗаказПоставщику
    |                ИЛИ ЗаказПоставщику = &Договор) КАК РасчетыСПоставщикамиПоДокументам
    |
    |УПОРЯДОЧИТЬ ПО
    |    РасчетыСПоставщикамиПоДокументам.РасчетныйДокумент.Дата УБЫВ
    |";
    
    Запрос.УстановитьПараметр("Дата",             Новый Граница(Документ.МоментВремени(), ВидГраницы.Исключая));
    Запрос.УстановитьПараметр("ЗаказПоставщику", ?(ЗначениеЗаполнено(Документ.ЗаказПоставщику), Документ.ЗаказПоставщику, Документ));
    Если ЗначениеЗаполнено(Документ.Договор) Тогда
        Запрос.УстановитьПараметр("Договор",    Документ.Договор);
    Иначе
        Запрос.Текст = СтрЗаменить(Запрос.Текст, "ЗаказПоставщику = &Договор", "АналитикаУчетаПоПартнерам.Контрагент = &Контрагент");
        Запрос.УстановитьПараметр("Контрагент", Документ.Контрагент);
    КонецЕсли;
    
    Выборка = Запрос.Выполнить().Выбрать();
    Превышение = ПредоплатаПревышающая - Документ.СуммаДокумента; Сумма = 0; СуммаУпр = 0;
    Пока Выборка.Следующий() Цикл
        Если Превышение > 0 И Выборка.ПредоплатаПриход >= Превышение Тогда
            Сумма =       Сумма    + Выборка.ПредоплатаПриход - Превышение;
            СуммаУпр = СуммаУпр + Выборка.ПредоплатаУпрПриход - Превышение * Выборка.ПредоплатаУпрПриход/Выборка.ПредоплатаПриход;
            Превышение = 0;
        Иначе
            Сумма =       Сумма    + Выборка.ПредоплатаПриход;
            СуммаУпр = СуммаУпр + Выборка.ПредоплатаУпрПриход;
        КонецЕсли;
        Если Сумма >= Документ.СуммаДокумента Тогда
            Прервать;
        КонецЕсли;
    КонецЦикла;
    Возврат ?(Сумма > 0, СуммаУпр/Сумма, 0);
    
КонецФункции

Можно их было объединить в один запрос по остаткам и оборотам, но сложно...
   Mikhail Volkov
 
43 - 29.02.16 - 17:06
"Переоценка валютных средств" (Расчет курсовых разниц) какой мутный документ!? Ничего толком про него не написано, везде это воспринимается как некая игра на курсе валют!?
Если вести управленческий с учетом курсовых разниц, то он на фиг не нужен... если бы не ошибки округления при пересчете валют.
   Mikhail Volkov
 
44 - 29.02.16 - 19:04
Как формируются суммы поступления и списания этого документа?
   shuhard
 
45 - 29.02.16 - 19:50
(43) тяжёлый клинический бред


Список тем форума
 
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.