Вход | Регистрация
 

Вопрос по работе 1С под Linux

Вопрос по работе 1С под Linux
Я
   LLIaMaH
 
02.02.16 - 08:34
Поставили 8.3 под линукс Дебиан 8, скопировал файловую базу ЗуП, толстый клиент, при выгрузке отчетности ПФР выдает ошибку https://yadi.sk/i/aY96iyqmo6Ug3 В выгрузке есть следующий код:

Кат = Новый Файл(ПутьДляВыгрузки + "NUL");        
Если НЕ Кат.Существует() Тогда
    Текст = "Нет доступа к каталогу " + ПутьДляВыгрузки + ".";
    Если ЭлементыФормы.СохрНаДискету.Значение = 1 Тогда
    Текст = Текст + Символы.ПС + "Вставьте дискету в дисковод!";
Иначе
    Текст = Текст + Символы.ПС + "Проверьте корректность имени каталога выгрузки!";
КонецЕсли;
    Предупреждение(Текст);
    Возврат;
КонецЕсли;

Под виндрой и Вайн-Линукс эта выгрузка работает нормально. Решил проверить принцип работы своей отдельной обработкой, скопировал все тоже самое за исключением места  ПутьДляВыгрузки + "NUL"  

Кат = Новый Файл(ПутьКФайлуВыгрузки);
Если НЕ Кат.Существует() Тогда
    Текст = "Нет доступа к каталогу " + ПутьКФайлуВыгрузки + ".";
    Текст = Текст + Символы.ПС + "Проверьте корректность имени каталога выгрузки!";
    Предупреждение(Текст);
    Возврат;
Иначе    
    Предупреждение("ОК!!");
КонецЕсли;

Так вот че это за добавка к Пути  «+ "NUL"» с ней моя обработка не срабатывает ни под какой ОС, без этой добавки проверка наличия файла выполняется, при этом выгрузка ПФР работает тока под виндой и вайном.

До кучи есть ряд вопросов по работе линукс платформы.
1) Выпадающие менюшки глючат, бывает нажмешь на кнопку с меню а она не выпадает, чуть мышкой двинул вниз меню и появляется, я руку набил, не замечаю, а бухи нудят что тормозит меню.
2) При печати на на принтер НР обрезает кусок строки сверху, обычно Табличный макет там имеет пустую строку и это не заметно, но есть формы у который есть текст в притык к верхней границе, НР его обрезают, а Киосера например нет. С дровами играться или настройки где какие делать.
   zak555
 
1 - 02.02.16 - 08:39
библиотнки для клиента ставил ?
   LLIaMaH
 
2 - 02.02.16 - 08:58
(1) Занимался настройкой и установкой админ. Я почти полный ноль. Скорее всего при установке ставил все библиотеки какие требовались при установке по зависимостям
   dmrjan
 
3 - 02.02.16 - 09:23
Скорее всего или неправильно прописан путь (регистры или русские буквы) или же права к каталогу обмена были созданы под root, пусть администратор проверит.
   dmrjan
 
4 - 02.02.16 - 09:25
В том плане, что нужно задать права на каталог под ту учетку, под которой работает 1С сервер.
   dmrjan
 
5 - 02.02.16 - 09:30
На внешний HDD выгрузка идет?
   Глупый дятел
 
6 - 02.02.16 - 09:34
ну а в целом то как 1с на лине работает, есть смысл переходить?
   ЛисИзЛеса
 
7 - 02.02.16 - 09:44
(6) В целом 1С на "лине" работает.
Если у Вас пользователи работают под linux, то можно и на 1С работать.
Если у Вас официальные лицензии под Windows, то работайте на Windows
   LLIaMaH
 
8 - 02.02.16 - 09:58
(3-5) У нас файловый вариант под Линухой, запуск платформы получается от моего имени идет, папки эти я сам создаю, по идее должны быть доступны, в любом случае моя обработка работает с этими папками, выгрузка в БП20 тоже работает, хотя там идет ругань на СОМ, но файл формируется и выгружается без проблем. А тут похоже дело именно в этих методах работы с объектом Файл, Кат.Существует(), потому как в моей обработке он отрабатывает нормально, в случае выгрузки в ПФР выдает Ложь, но под виндами и вайном все нормально.
   LLIaMaH
 
9 - 02.02.16 - 10:09
(6) Если есть лицензии ан винду, я бы однозначно оставался на винде. Мы же работал под ваном, вот это реальная лажа была. Нативный клиент под линукс пока вызывает двоякие чувства, он лучше вайна, но целиком работать как под виндой всеранво не может, постоянно встречаются каки-то затыки. В целом рано или поздно пользователи учатся с этим работать или ваще про проблемы не узнают, но я не уверен что если юзать функционал типовый на полную катушку, то рано или поздно не встрянешь, напримиер нет поддержки СОМ объектов, всякие внешние компоненты не поддерживаются. В целом основной функционал работает.
   LLIaMaH
 
10 - 02.02.16 - 10:31
В целом пробелма временно решилась преобразованием строки:

Кат = Новый Файл(ПутьДляВыгрузки + "NUL");
В
Кат = Новый Файл(ПутьДляВыгрузки);        

Информации о том что это за "NUL" я нигде не нашел, может какая недокументированная фича или еще че и нативный клиент 8.3, с ней работать не умеет.

Список тем форума
 
Глупец, лишенный способности посмеяться над собой вместе с другими, не сможет долго выносить программирование.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.