Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: V83.ComConnector и дата в 8.3

v7: V83.ComConnector и дата в 8.3
Я
   Абыр
 
16.04.15 - 16:31
Подключение из 7.7 в 8.3
Соединение = СоздатьОбъект("V83.COMConnector");
СтрокаПодключения =  "srvr='" + Сервер + "'; ref='" + БазаДанных + "';";
База = Соединение.Connect(СтрокаПодключения);
Дата83 = База.Дата("20150101000000");

Подключение работает)
Но ругается на "Поле агрегатного объекта не обнаружено (Дата)".
Как в комконнекторе из 7.7 получить восьмерошную дату?
   Serginio1
 
1 - 16.04.15 - 16:42
(16) Тебе проще использовать внешнюю обработку. Семерка кучу типов не понимает.
Плюсы отладка на стороне базы
v8: 8.2, COM-соединение, C#, dynamic строки
   Serginio1
 
2 - 16.04.15 - 16:51
   Абыр
 
3 - 16.04.15 - 17:01
что-то не пашет через eval. или я одаренный
работает вариант с База.ЗначениеИзСтрокиВнутр(), но это изврат)
   Serginio1
 
4 - 16.04.15 - 17:07
(3) Посмотри 2 там не зря сделаны функции во внешнем отчете

В модуле внешней обработки создать
Функция ВычислитьВыражение(Выражение) Экспорт
  возврат вычислить(Выражение);    
КонецФункции

Функция ВычислитьСвойствоОбъекта(Объект,Свойство) Экспорт
  возврат Объект[Свойство];    
КонецФункции

Процедура УстановитьСвойство(Объект,Свойство,Значение) Экспорт
Объект[Свойство]=Значение
КонецПроцедуры
   Александр Б
 
5 - 16.04.15 - 17:14
(0) попробуй База.Date("20150101000000");
   Абыр
 
6 - 16.04.15 - 17:20
(5) с Date попробовано - не канает
   Александр Б
 
7 - 16.04.15 - 17:25
(6) а мне помогало. Была похожая ситуация. Только в моем случае string сработал, вместо Строка
   Рэйв
 
8 - 16.04.15 - 17:27
(0)И какую ты дату хочешь получить от БАЗЫ, к которой подключился?
   Рэйв
 
9 - 16.04.15 - 17:28
>>База = Соединение.Connect(СтрокаПодключения);
Дата83 = База.Дата("20150101000000");

Это просто соединение.Канал. У этого канала даже методов нет.
Учите уже  буквари
   Абыр
 
10 - 16.04.15 - 17:29
(7) это потому что у внешнего соединения есть метод String()
(8), (9) с этим уже разобрался)
   Абыр
 
11 - 16.04.15 - 17:30
(9) и методы есть. целых два)
   Рэйв
 
12 - 16.04.15 - 17:31
(11)нука-нука?:-)
   Абыр
 
13 - 16.04.15 - 17:32
(12)
как-то так:
http://take.ms/BwIUI
   Рэйв
 
14 - 16.04.15 - 17:34
(13)Ну да:-) Есть. Молодец что помнишь.
   Рэйв
 
15 - 16.04.15 - 17:35
А я пользуюсь не задумываяь о родительских классах:-))
   Рэйв
 
16 - 16.04.15 - 17:37
Вернее забываю просто

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.