Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

УТ 11 создание документа Установка цен номенклатуры

УТ 11 создание документа Установка цен номенклатуры
Я
   SeregaMW
 
19.01.15 - 14:23
Пишу так

        Док.Дата = ТекущаяДата();
        Док.ДокументОснование = ДокПоступление;        
        ВидЦен = Док.ВидыЦен.Добавить();
        ВидЦен.ВидЦены = Объект.ТипЦенПродажи;
    КонецЕсли;
    
    тчТовары = Док["Товары"];
    Для каждого строка из Объект.Номенклатура Цикл
        Объект1 = тчТовары.Добавить();
        Объект1["Номенклатура"] = Справочники.Номенклатура.НайтиПоНаименованию(Строка.Номенклатура);
        Объект1["Цена"] = строка.ЦенаИнетМагазина;
        //    Стр= Док.Товары.Добавить();        
        //    Стр.Номенклатура = Справочники.Номенклатура.НайтиПоНаименованию(Строка.Номенклатура);
        //    Стр.Характеристика    = Справочники.ХарактеристикиНоменклатуры.НайтиПоКоду(Строка.Характеристика,,,СТрока.ВидНоменклатуры);
        //    Стр.Цена = строка.ЦенаИнетМагазина;
        //    Стр.ВидЦены = Объект.ТипЦенПродажи;
    КонецЦикла;

Документ записывается и проводится, но при попытки его открыть пишет
{ОбщийМодуль.УстановкаЦенСервер.Модуль(3475)}: Поле объекта не обнаружено (ВидЦены1b1d6502568d11e4acbc50465d50abe9)
                        ЭлементНоменклатура[                     ИмяКолонки] = ВыборкаВидыЦен.Цена;

Все дело в том что я не заполняю реквизит НастройкиКомпоновкиДанных в ТЧ.ВидыЦен

Как его заполнить ума не приложу, смотрел в отладчике вообще не въехал, помогите.
 
 
   ДенисЧ
 
1 - 19.01.15 - 14:25
номер строки типа цен не заполняешь?
   SeregaMW
 
2 - 19.01.15 - 14:26
(1) нет
   ДенисЧ
 
3 - 19.01.15 - 14:27
(2) Наивный вопрос - а почему?
   SeregaMW
 
4 - 19.01.15 - 14:30
(3) Заполнил, документ стал открываться, ошибка пропала, но теперь при открытии в ТЧ.ВидыЦен указаны все виды цен, а галочки на моем типецен который прописан в коде нет, как ее поставить программно?
   SeregaMW
 
5 - 19.01.15 - 15:20
Если добавляешь тип цен в ТЧ товары то ошибка не куда не исчезает

    ВидЦен = Док.ВидыЦен.Добавить();
        ВидЦен.ВидЦены = Объект.ТипЦенЗакупки;
        ВидЦен.НомерСтроки = 1;
    КонецЕсли;
    
    тчТовары = Док["Товары"];
    Для каждого строка из Объект.Номенклатура Цикл
        Объект1 = тчТовары.Добавить();
        Объект1["Номенклатура"] = Справочники.Номенклатура.НайтиПоНаименованию(Строка.Номенклатура);
        Объект1["Цена"] = строка.ЦенаИнетМагазина;
        Объект1["ВидЦены"] = Объект.ТипЦенЗакупки;


Ошибка при открытии документа
{ОбщийМодуль.УстановкаЦенСервер.Модуль(3475)}: Поле объекта не обнаружено (ВидЦены62b7b4c5548b11e4bb7050465d50abe9)
                        ЭлементНоменклатура[                     ИмяКолонки] = ВыборкаВидыЦен.Цена;
   SeregaMW
 
6 - 19.01.15 - 18:27
апну
   ProxyInspector
 
7 - 19.01.15 - 21:54
Так ты чего еще не сделал?
Напиши релиз УТ11. В одном из последних релизов документ "Установка цен номенклатуры" давал подобные ошибки. Разработчики начали менять логику работы и бросили. Получился кривой релиз. Ты попробуй ручками создай документ.
Мне пришлось брать документ "Установка цен номенклатуры" из прошлого релиза.
   SeregaMW
 
8 - 19.01.15 - 23:12
Руками документ создается корректно, релиз УТ  11.1 (11.1.9.56)
   SeregaMW
 
9 - 20.01.15 - 11:51
апну

Есть у кого ни будь пример программного создания документа Установка цен номенклатуры для УТ 11

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует