Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как сделать такую группировку в скд?

Как сделать такую группировку в скд?
Я
   Miss1C
 
31.10.12 - 19:56
http://i051.radikal.ru/1210/28/5dd297e70386.bmp Нужно чтобы документ "РеализацияТоваровУслуг" находился под "ТАРА" подскажите как нужно разместить поля
 
 
   Один С
 
1 - 31.10.12 - 19:58
хренасе, а чо так можно?
   Один С
 
2 - 31.10.12 - 19:58
аа, все понял. "документ" это ресурс типа..
   Miss1C
 
3 - 31.10.12 - 20:02
(2)Да
   Один С
 
4 - 31.10.12 - 20:02
в скд, в выбранных полях можно крутить полями как хочешь. там можно и группы создавать.
   Miss1C
 
5 - 31.10.12 - 20:03
(4)Пробовала, без результатов
   Miss1C
 
6 - 31.10.12 - 20:09
   PR
 
7 - 31.10.12 - 20:12
Расположение полей группировок = Отдельно и только в итогах
   PR
 
8 - 31.10.12 - 20:12
В "Другие настройки"
   Miss1C
 
9 - 31.10.12 - 20:15
(7)По отчету или по колонке?
   Miss1C
 
10 - 31.10.12 - 20:27
(7)Не помогло
 
 Рекламное место пустует
   Лефмихалыч
 
11 - 31.10.12 - 20:29
(0) СКД этого до сих пор не умеет, живи с этим. Группировка колонок адинэсникам недоступна
   Miss1C
 
12 - 31.10.12 - 20:33
(11)Не может этого быть
   PR
 
13 - 31.10.12 - 20:33
(9) Можно по всему отчету.
   Лефмихалыч
 
14 - 31.10.12 - 20:34
(12) и тем не менее, смирись и ищи способы с этим жить, я уже говорил
   PR
 
15 - 31.10.12 - 20:34
(10) Тебе нужно чтобы разные группировки по колонкам были в разных строках? Тогда это именно то, что тебе нужно.
   PR
 
16 - 31.10.12 - 20:35
(11) С чего бы это вдруг?
   Лефмихалыч
 
17 - 31.10.12 - 20:35
(16) с того, что в настройках их сгруппировать можно, но по факту после вывода получается сабж
   PR
 
18 - 31.10.12 - 20:40
(17) Ты проверял?
   Лефмихалыч
 
19 - 31.10.12 - 20:51
(18) да v8: СКД: СКД, иерархия группировок колонок, лыжи не едут...
правда это было какое-то время назад. А чо, что-то поменялось?..
   PR
 
20 - 31.10.12 - 20:56
(19) Так попробуй.
   vmv
 
21 - 31.10.12 - 21:05
(0) никак, все что писали выше бред

но простой постобработкой в конце метода ПриКопмоновкеРезультат()

можно отловить все шапки группировок(таблиц) и объединить исключительно колонки шапок красиво и внятно, причем как по вертикали, так и по горизонтали.

Я довно прикрутил этот механизм ко всем отчетам и не парюсь.

Замечу 1, что блуждающие тут подобные технологии делают постобработку всего ДокументРезультат, моя только шабки в том числе и шапку строк таблиц СКД, т.е. снизу/вверх слева.

Замечу 2, что использование этой техологии совершенно не нарушает типовые механихмы компоновки, просто добавляем вызов в конец указанного выше медода
Если ПостобработкаШапок Тогда
ПостобработкаШапок(ДокументРезультат);
КонецЕсли;

Спасибо, что прослушали эту рекламу.

буду бухать - выложу, ибо СКД НЕ УМЕЕТ делать слияние "однородных колонок" в шапках
   Лефмихалыч
 
22 - 31.10.12 - 21:11
(20) ты хочешь сказать, что, если я попробую, то оно заработает?
   vmv
 
23 - 31.10.12 - 21:14
(22) я пока 8.2.14 как то с месяц параллельно пытался научить СКД сливаться в шапках - хрена не умеет, посему заставил ее сделать свое и потом расчехлить табдок без эффектов зазадерки и без тупняковых обходов всех и вся)
   sanja26
 
24 - 31.10.12 - 21:15
(6) попробуй вид документа всунуть в саму группировку вид взаиморасчетов
   Лефмихалыч
 
25 - 31.10.12 - 21:16
(20) ты сам попробуй, загадочная личность. Как я и говорил в (11) - оно не работает:
http://gyazo.com/25e7d200bfd64f582f59855592ebc21e
   sanja26
 
26 - 31.10.12 - 21:16
+(24) и сделать именно для нее вывод горизонтально
   sanja26
 
27 - 31.10.12 - 21:19
все должно делаться, умники. как по вашему период месяц в колонки выводится, а под ним разбивка по дням допустим
   vmv
 
28 - 31.10.12 - 21:19
(26) да можно в СКД достичь эффекта как в табличном поле

колонка заглавная, а под ней подчиненные, но над каждой подчиненной будет эта заглавная, вот эту кучку заглавных СКД и не умеет слить, впрочем это и не ее дело, даже в экселе в таком случае использут ручную или макросовскую операцию объединить, но в СКД это проще, но программно)
   vmv
 
29 - 31.10.12 - 21:22
(27) в плоскости колонок да, а с плюсиками(включенными группами) - не то, попробуй.

Самое паршивое, что со свернутыми группами - это "экономный вид" отчета для печати и он несет избыточную инфу и надписи в колонках, если с ним ничего не делать
   vmv
 
30 - 31.10.12 - 21:23
+27() я имею ввиду когда месяцы в тираже и сгруппированы

январь ... февраль...
1.2.3..... 1.2..
   Лефмихалыч
 
31 - 31.10.12 - 21:25
(27) при помощи кастомных макетов этого можно добиться, но это не универсальное решение
   vmv
 
32 - 31.10.12 - 21:27
(31) макеты в самой СКД зависят от состава или имен группировок, полей - да это лажа
   PR
 
33 - 31.10.12 - 21:32
(21) И откуда вы такие беретесь?

(22), (25) Ну да, конечно не работает, если не знать как.

Картинка
http://asbins.ru/SKD.png

Текст запроса
ВЫБРАТЬ
    1 КАК Значение
ПОМЕСТИТЬ Цифры

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
    2

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
    3
;

 ////////////////////////////////////////////////////////////////////////////////
 
ВЫБРАТЬ
    "А" КАК Значение
ПОМЕСТИТЬ Буквы

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
    "Б"

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
    "В"
;

 ////////////////////////////////////////////////////////////////////////////////
 
ВЫБРАТЬ
    "I" КАК Значение
ПОМЕСТИТЬ Римские

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
    "II"

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
    "III"
;

 ////////////////////////////////////////////////////////////////////////////////
 
ВЫБРАТЬ
    Цифры.Значение КАК Цифра,
    Буквы.Значение КАК Буква,
    Римские.Значение КАК Римская
ИЗ
    Цифры КАК Цифры
        ВНУТРЕННЕЕ СОЕДИНЕНИЕ Буквы КАК Буквы
        ПО (ИСТИНА)
        ВНУТРЕННЕЕ СОЕДИНЕНИЕ Римские КАК Римские
        ПО (ИСТИНА)

 
 
   PR
 
34 - 31.10.12 - 21:35
+(33) http://asbins.ru/SKD.erf для тех, кому лень создавать отчет.
   vmv
 
35 - 31.10.12 - 21:36
(33) так хрень у тебя на картинке, что за пустые ячейки после группировок колонки таблицы 1, 2, 3

почему они пусты, зачем они там, какой от них смысл тебе не задавали такой вполне резонный вопрос?

надо так
......-........|......-........|
......1........|......2........|
   vmv
 
36 - 31.10.12 - 21:38
+(35) да и сама колонка группировок 1, 2, ... в представленном примере, как правило, в ресурсах несет чушь, а ведь должна нести первую колонку вложенных деталей)
   PR
 
37 - 31.10.12 - 21:38
(35) Не тупим. В них показываются итоги.
   Лефмихалыч
 
38 - 31.10.12 - 21:39
утыёпт!.. PR, уел. Оно работает.
Правда выглядит при этом по-уродски, но работает! Век живи, век учись
   vmv
 
39 - 31.10.12 - 21:40
(37) итоги в шапке колонок таблицы, бгг - не тупим.
   Лефмихалыч
 
40 - 31.10.12 - 21:44
(35) это СКД не осиливает объединить ячейки шапки родительской группировки. В остальном работает.
Всё-тки СКД - это грёбаное вуду. Чертовски хорошее, но все равно вуду...
   PR
 
41 - 31.10.12 - 21:44
(39) Я не понимаю твой французский.
Дополнительная колонка для 1, 2 и 3 нужна по двум причинам:
1. В этой колонке показываются итоги по группировке по цифрам.
2. В эту колонку сворачивается по плюсику вторая группировка, то есть I, II и III.
   PR
 
42 - 31.10.12 - 21:46
+(41) Если ты про то, что нахрена над I, II и III пустые ячейки, то на мой взгляд сиренево, с чем объединять 1, 2 и 3, с ячейкой снизу или с тремя ячейками справа.
   vmv
 
43 - 31.10.12 - 21:47
(40) я об этом и писал выше и с точки зрения СКД это правильно - она умная, но не настолько, чтобы заниматься анализом ассоциативных ВИДОВ, напрямую не связанных с данными БД.

Свое решение проблемы сабжа выложу в ноябре
   PR
 
44 - 31.10.12 - 21:48
+(42) Хотя нет, лучше бы конечно объединять с тремя левыми, если будет длинное наименование в первой группировке, получится лучше.
Но это уже к Нуралиеву, я такими мелочами не занимаюсь :))
   vmv
 
45 - 31.10.12 - 21:50
(42) я спросил четко и внятно - зачем пустые ячейки в шапке верхней группировки КОЛОНОК таблицы примера?)

убери их средствами одной СКД и я буду считать что у тебя еще длинее)
   vmv
 
46 - 31.10.12 - 21:51
(44) передай Нуралиеву, что заниматься этим уже не нужно, можно купить у меня готовое решение за символическую цену)
   Лефмихалыч
 
47 - 31.10.12 - 21:51
полно-те вам, господа, пинусами мериться - у дельфина все равно длиннее
   vmv
 
48 - 31.10.12 - 21:52
(47) я всегда думал, что у моржа(
   PR
 
49 - 31.10.12 - 21:53
(45) Да какая разница, что _ты_ спросил?
ТС спросила совершенно другую тему, а ты в () написал, что невозможно.
 
 Рекламное место пустует
   PR
 
50 - 31.10.12 - 21:53
+(49) В (21) в смысле.
   Лефмихалыч
 
51 - 31.10.12 - 21:54
а ТС по ходу пошла учиться жить с тем, что это не возможно...
   vmv
 
52 - 31.10.12 - 21:55
(49) она спросила именно эту тему, просто я переводчик с женской логики на человеческую и всякий дурацкий вопрос понимаю правильно. так проблема не в теме, а том, что СКД тупит, но это исправимо)
   PR
 
53 - 31.10.12 - 22:00
(52) Почему бы просто не признаться, что ты облажался и перестать рекламировать свои платные 10 строчек кода :))
   PR
 
54 - 31.10.12 - 22:00
+(53) Это как бы вопрос, но риторический, поэтому без знака вопроса :))
   Miss1C
 
55 - 01.11.12 - 11:13
(21)Где эта обработка, покажите мне ее)
   Miss1C
 
56 - 01.11.12 - 11:17
АП
   PR
 
57 - 01.11.12 - 12:37
(55) Зачем тебе?
   samozvanec
 
58 - 01.11.12 - 12:40
макет предлагали?
   ИС-2
 
59 - 01.11.12 - 12:44
(0) ну, что же фотка делают. Знаю, что опаздаю, но на вопрос отвечу
v8: Как можно вывести 3-х этажную шапка в СКД

сейчас код найду
   ИС-2
 
60 - 01.11.12 - 12:45
Процедура ДействияФормыСформировать(Кнопка)
 //    ЭлементыФормы.Результат = Новый ТабличныйДокумент;
 
    РежимРасшифровки = Ложь;

    ТабДок = ЭлементыФормы.Результат;
    
    ТабДок.Очистить();
    
    ЭтотОбъект.СкомпоноватьРезультат(ТабДок,ДанныеРасшифровки);
    
    Состояние("Обработка колонок...");
    
    ОбработатьЗаголовки(ТабДок);
    
    Отчеты.УниверсальныйОтчет.Создать().РасчетШириныКолонок(ТабДок);
КонецПроцедуры

Процедура ОбработатьЗаголовки(ТабДок)

    ОбъединяемаяОбласть = Неопределено;

   //Для оптимизации здесь нужно будет ограничить высоту таблицы
 
   //Для индСтр=1 По ТабДок.ВысотаТаблицы Цикл
 
    Для индСтр=1 По 10 Цикл

        НачальнаяКолонка = 0;
        Для индКол=1 По ТабДок.ШиринаТаблицы Цикл

           // ресурсы не обрабатываем
 
            ТекИмяПоля = ТабДок.Область(индСтр, индКол).Текст;
            Если не СхемаКомпоновкиДанных.ПоляИтога.Найти(ТекИмяПоля) = Неопределено Тогда 
                Продолжить;
            КонецЕсли;
            
           // определяем начало объединения
 
            Если ОбъединятьЯчейки(ТабДок, индСтр, индКол) Тогда

                Если не НачальнаяКолонка Тогда

                    НачальнаяКолонка = индКол;

                КонецЕсли;

            ИначеЕсли НачальнаяКолонка Тогда
               // завершаем объединение
 

                ТекстЗаголовка = ТабДок.Область(индСтр, индКол).Текст;
                ОбъединяемаяОбласть = ТабДок.Область(индСтр, НачальнаяКолонка, индСтр, индКол);
                ОбъединяемаяОбласть.Объединить();
                ОбъединяемаяОбласть.ГоризонтальноеПоложение = ГоризонтальноеПоложение.Центр;
                ОбъединяемаяОбласть.Текст = ТекстЗаголовка;
                НачальнаяКолонка = 0;

            Иначе

                НачальнаяКолонка = 0;

            КонецЕсли;

        КонецЦикла;

       // Если нашли в строке области для объединения, то прекращаем дальнейшие поиски
 
        Если не ОбъединяемаяОбласть = Неопределено Тогда

        //   возврат;
 

        КонецЕсли;

    КонецЦикла;

КонецПроцедуры

 // Проверка двух смежных ячеек на идентичночность
 
Функция ОбъединятьЯчейки(ТабДок, индСтр, индКол)

    Ячейка = ТабДок.Область(индСтр, индКол);
    ЯчейкаСлед = ТабДок.Область(индСтр, индКол+1);
    Если ПустаяСтрока(Ячейка.Текст) Тогда

        Возврат ложь

    ИначеЕсли
       //Проверяем на соответствие заголовка
 
        Ячейка.Текст = ЯчейкаСлед.Текст
       // Проверяем на соответствие имени (отсеиваем уже объединенные ячейки)
 
       //и Ячейка.Имя = "R"+индСтр+"C"+индКол 
 
        Тогда

        Возврат Истина;

    Иначе

        Возврат ложь

    КонецЕсли;

КонецФункции

взято с инфострара
   ИС-2
 
61 - 01.11.12 - 12:50
(56)
А может в отпуск в Киев съездить?
   PR
 
62 - 06.11.12 - 15:06
+(34) Только что обнаружил, что ссылка открывается как текст, для удобства сделал вместо erf rar.
http://asbins.ru/SKD.rar


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует