Вход | Регистрация
 

Активизировать поле ввода

Активизировать поле ввода
Я
   palm1c
 
15.06.11 - 16:46
Добрый день.

Как-то я подзабыл, подскажите, плиз.

Есть поле ввода. Нужно его программно активизировать. Как это сделать?

Делаю так:
Форма.Активизировать(ПолеВВода);
результат:
Поле агрегатного объекта не обнаружено (Активизировать)


Делаю так:
Активизировать("ПолеВВода");
Результат:
В данной формуле не может быть вызвана эта процедура(функция)

пасибо.
   palm1c
 
1 - 15.06.11 - 16:48
бамп
   palm1c
 
2 - 15.06.11 - 16:48
Все происходит во внешней обработке.
   fedoss
 
3 - 15.06.11 - 16:50
yandex.ru + "В данной формуле не может быть вызвана эта процедура(функция)" = ответ в первой ссылке
   ДенисЧ
 
4 - 15.06.11 - 16:50
Откуда вызываешь-то?
Через ложное закрытие делай...
   palm1c
 
5 - 15.06.11 - 16:52
Вызываю из своей процедуры.
   palm1c
 
6 - 15.06.11 - 16:52
(4) Как через ложное закрытие?
   palm1c
 
7 - 15.06.11 - 16:55
Сенкс.
   AllJoke
 
8 - 15.06.11 - 16:56
ЭлементыФормы.ИмяФайла.АктивизироватьПоУмолчанию
   AllJoke
 
9 - 15.06.11 - 16:56
Расширение элементов управления, расположенных на панели.АктивизироватьПоУмолчанию (Panel controls extension.DefaultControl)
Расширение элементов управления, расположенных на панели (Panel controls extension)
АктивизироватьПоУмолчанию (DefaultControl)
Использование:

Только чтение.
Описание:

Тип: Булево. Истина - элемент управления будет активизирован при открытии формы.

Доступность:

Толстый клиент.
Примечание:

На одной странице панели только один элемент управления может иметь значение данного свойства Истина. Установка свойства для другого элемента приводит к снятию свойства у элемента, для которого оно было установлено ранее.
   palm1c
 
10 - 15.06.11 - 16:56
(8) Не попал.
   palm1c
 
11 - 15.06.11 - 16:56
(9) v 7.7
   AllJoke
 
12 - 15.06.11 - 16:59
(11) ох сорри
   AllJoke
 
13 - 15.06.11 - 17:03
Активизировать(<?>,);
Синтаксис:
Активизировать(<ИмяРеквизита>,<Режим>)
Назначение:
Активизировать для редактирования поле диалога.
Параметры:
<ИмяРеквизита> - необязательный параметр. Строка с именем поля диалога, которое нужно активизировать. Пустое имя элемента диалога используется для активизации всей формы.
<Режим> -  необязательный параметр. Имеет смысл только для строк списков. Число: 1 - войти в режим редактирования, 0 - не входить. Значение по умолчанию - 1.
Замечание:
Метод  Активизировать может быть вызван из другого (внешнего) модуля, если в нем известен контекст формы, в которой нужно активизировать элемент диалога. Доступ к методу возможен только в контексте Модуля формы.
   Tatitutu
 
14 - 15.06.11 - 17:04
(4) правильный ответ
(13) не взлетит
   ДенисЧ
 
15 - 15.06.11 - 17:05
(13) не твой сегодня день...

Процедура ЗдесьНужноНоНельзяАктвизировать()
  флЛожноеЗакрытие = 1;
  Форма.Закрыть(0);
КонецПроцедуры

Процедура ПриЗакрытии()
  Если флЛожноеЗакрытие = 1 Тогда
    флЛожноеЗакрытие = 0;
    Форма.Активизировать(НужноеПоле);
    СтатусВозврата(0);
    Возврат;
  КонецЕсли;
   AllJoke
 
16 - 15.06.11 - 17:06
Процедура Активист()
    Активизировать("КонДата");
КонецПроцедуры
   AllJoke
 
17 - 15.06.11 - 17:06
(16) взлетело
   palm1c
 
18 - 15.06.11 - 17:09
(15) Спасибо.

Нашел еще вот это В данной формуле не может быть вызвана эта процедура(функция)

Но не взлетоло почему-то.
   Mikeware
 
19 - 15.06.11 - 17:14
(15) я не помню ни одного "его" дня :-))

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.