Вход | Регистрация
 

"Перегрузка документа" Изучаю 1С четвёртый день :)

Я
   Nikitvol
 
08.10.10 - 20:51
Всем Привет!

Ребят, устраиваюсь на работу (в сфере 1С); дали там задание, мол если сделаешь, то на собеседование позовем.
Я с 1С 4ый день знаком, поэтому только основы узнал.

Так вот задание (выполняется в 1С:Предприятие 8.2):
Необходимо с помощью программных средств языка 1С написать внешнюю обработку «Перегрузка документа».
На форме находятся 2 поля: в одном выбираем документ, в другом файл; и две кнопки: "Выгрузить" и "Загрузить"
По кнопке «Выгрузить» информация, содержащая в выбранном документе, выгружается в указанный файл.
По кнопке «Загрузить», из указанного файла, в базе создается копия исходного документа (за исключением номера документа, так как номера документов в системе уникальные).
При написании обработки необходимо использовать элемент языка «Метаданные.…».

Форму я сделать смог, как в полях документ и файл выбирать разобрался, а вот какие процедуры нужно написать к кнопкам (точнее как их написать) не допираю :( :(
Я так понял, что нужно документ выгружать в xml или txt файл... А потом из файла загружать...

На форуме искал похожие темы, находил, но они не помогали :(
Помогите пожалуйста, кто чем сможет :)

P.S. Не судите строго, я пока нуб в 1С :)
   Shutov
 
1 - 08.10.10 - 20:54
(1) Сиринт? :)
   AlexNew
 
2 - 08.10.10 - 20:56
(0) Иди туда, где сначала не дают тестовые задания, побегаешь, научишься (может быть).
   nick slaughter
 
3 - 08.10.10 - 20:58
Ну подскажут вам тут как обработку сделать, а на собеседовании то чо делать будете? Все равно ж завалитесь.
   Garlic
 
4 - 08.10.10 - 20:58
(0) В пятницу? На ночь глядя? - Иди девчонок окучивай!
   Shutov
 
5 - 08.10.10 - 21:00
Ребята, это было первое задание, вы хотите знать какое второе задание для стажера? %)
   Nikitvol
 
6 - 08.10.10 - 21:02
(1) да, а откуда знаешь?
(2) без тестовых заданий и бегать не не захочется!
(3) на первом же собеседовании (когда задание давали) их не испугало то что я не знаю 1С.
   AlexNew
 
7 - 08.10.10 - 21:06
(6) Отлично, иди без задания, им ИТС разносить некому, сначала обновлять научишься, дальше - как пойдет.
   Shutov
 
8 - 08.10.10 - 21:07
(6) Сам делал в 2005-ом такое задание 8)
Привет передавай Савлюку Вячеславу и Вадиму Михайловичу из Москвы, если устроишься на работу.

На самом деле у "Сиринта" подход очень простой, и, как показала практика, верный и работающий - они берут толковых студентов на 3-4-ом курсах из ИТ-специальностей (без каких-либо знаний 1С!), прокачивают их заданиями (около 10-ти различных) по сферам программирования в 1С, бухгалтерии и т.п., а потом под руководством ведущего специалиста ставят на проект в должность младшего программиста. Человек, если он толковый, быстро "прокачивается" и через 2 года сам может вести проекты. Реально.
   Shutov
 
9 - 08.10.10 - 21:07
(7) Модель продвижения стажера через ИТС и разъезды к клиенту ИМХО сливная, на такую работу "звезд" не наберешь!
   AlexNew
 
10 - 08.10.10 - 21:10
(9) Правда? Наш бывший курьер сейчас нормально работает как самостоятельный прог. Кто к чему стремится.
   Nikitvol
 
11 - 08.10.10 - 21:14
(8) Обязательно передам привет :) Помоги только пожалуйста!!! :) Хоть чем нибудь.
   AlexNew
 
12 - 08.10.10 - 21:22
Думаю, что сериализация и заполнитьзначениясвойств(). По-моему самый короткий путь.
   Heckfy
 
13 - 08.10.10 - 21:23
(5) Мочи второе задание  
:):):
   Nikitvol
 
14 - 08.10.10 - 21:26
(12) а можно небольшой пример, пжалуста!
   GenV
 
15 - 08.10.10 - 21:26
(0) Лучше начинать с книг. Толку будет больше. Например, "1С:Предприятие 8.0. Простые примеры разработки" А.П. Габец, Д.И. Гончаров. Там есть полезная для тебя инфа.
   Shutov
 
16 - 08.10.10 - 21:31
(12) Сериализацию использовать нельзя.
Цель задания - чтобы человек сам разобрался с различными типами объектов в системе, в первую очередь со справочниками и документами.
(11) На базе какой конфигурации делаешь задание?
   AlexNew
 
17 - 08.10.10 - 21:32
СXDTO = Новый СериализаторXDTO(ФабрикаXDTO);
    Файл=Новый ЗаписьXML;
    Файл.ОткрытьФайл(СокрЛП(ИмяФайлаДанных));
    Файл.ЗаписатьНачалоЭлемента("root");
    Для каждого Строка Из Объекты Цикл
        Если ЗначениеЗаполнено(Строка.Объект) Тогда
            СXDTO.ЗаписатьXML(Файл,Строка.Объект.ПолучитьОбъект());
        КонецЕсли;
    КонецЦикла;
    Файл.ЗаписатьКонецЭлемента();
    Файл.Закрыть();
Если поможет.
   Shutov
 
18 - 08.10.10 - 21:32
(13) Второе задание - это 7 вопросов по бухгалтерскому учету, нужно понимать что такое счет, проводка, план счетов, баланс, субконто и т.п. знать 5 основных проводок. В легкую за 1 неделю с книгами это все можно самостоятельно пройти и разобраться.
   AlexNew
 
19 - 08.10.10 - 21:34
(16) Пачиму? Они не знают как это работает?
   Shutov
 
20 - 08.10.10 - 21:36
(15) Книги книгами, но реально с Конфигуратором и справкой быстрее.
(17) Крутой код :)
(1) Начни с того, чтобы написать по нажатию кнопки "Выгрузить" обход полей документа вне зависимости от того, какой тип документа выбран - используй объект "Метаданные", тип документа - определяй по выбранному документу пользователем. Затем к этому обходу прикрути сохранение в текстовый файл, типа в таком формате:
"Док.РеализацияТоваровИУслуг
Номер=0001234
Дата=21.08.10
= Реквизиты документа =
Реквизит1=
Реквизит2=
Реквизит3=
..."
   Nikitvol
 
21 - 08.10.10 - 21:37
(15) Спасибо, полистаю, а Предприятие 8.0 сильно отличается от Предприятия 8.2?
P.S. Я тут уже прочитал половину книги: Радченко М., Хрусталева Е. 1C Предприятие 8.2 Практическое пособие разработчика.
(16) Я сам начал свою конфигурацию делать по книге. Это одно из условий задания.
(18) вот это второе задание, идёт у меня вместе с первым. Его я сделал, два дня потратил.
   Shutov
 
22 - 08.10.10 - 21:37
(16) С сериализацией смысл написания обработки теряется. Человек должен понять, что элементы справочника нужно читать по коду, документы искать по номеру и дате и т.д.
   Shutov
 
23 - 08.10.10 - 21:40
(21) 8.0 от 8.2 в том виде, котором тебе нужно, не отличаются.
Я вообще учился по книжке к 7.7 :) Вбивал оттуда код и не мог понять почему он в 8-ке не работает.
Советую для тестирования брать не свою новую пустую конфигурацию, а возьми 1С:Бухгалтерию 8 или 1С:УПП 8 - там все те нюансы, которые ты упустишь, будут сразу видны. У тебя принимать задание будут именно на одной из таких конфигураций.
Реально уже решил задачу по бухгалтерии? Все, принято?
   Nikitvol
 
24 - 08.10.10 - 21:40
(17) я конечно смутно понял, возьму этот код на заметку.
(22) "элементы справочника нужно читать по коду, документы искать по номеру и дате и т.д." т.е. использовать метаданные???
   AlexNew
 
25 - 08.10.10 - 21:41
(22) Бред. С автомобилями теряется смысл велосипедов.
   GenV
 
26 - 08.10.10 - 21:42
(20) Как говорится, кому как. Тем более там есть примеры и без сериализации.
(21) Смотря в каком режиме. В управляемом приложение отличается логика.
   Shutov
 
27 - 08.10.10 - 21:45
(24) Тебе нужно:
а) Понять какой тип документа у тебя выбрал пользователь в реквизите "Документ" - например, "РеализацияТоваровИУслуг";
б) Обратиться через объект "Метаданные" к метаданным этого документа - типа Метаданные["РеализацияТоваровИУслуг"];
в) Обойти у этого типа документов его метаданные циклом - типа
Для Каждого Реквизит Из Метаданные["РеализацияТоваровИУслуг"] Цикл
 ...
КонецЦикла
г) Каждый реквизит аккуратно положить файл в виде Реквизит.Имя + "=" + Реквизит.Значение.
Если это простой тип (строка, число и т.п.), то все ляжет просто. Если это тип (сложный) справочник, документ и т.д. подумай как его можно так сохранить, чтобы потом при восстановлении можно было восстановить каждый из таких сложных типов.
   Shutov
 
28 - 08.10.10 - 21:46
(26) Выгрузка документа, с точки зрения кода, не будет отличаться ни в управляемом режиме, ни в обычном ;)
   AlexNew
 
29 - 08.10.10 - 21:47
(22) По какому коду? Ты сам этот бред писал?
   Shutov
 
30 - 08.10.10 - 21:48
(25) и (29) По коду справочника. Чел, хватит троллить! Не сбивай человека.
 
 Рекламное место пустует
   GenV
 
31 - 08.10.10 - 21:50
(28) Хм.
Глобальный контекст (Global context)
Метаданные (Metadata)
Использование:
Только чтение.
Описание:
Тип: ОбъектМетаданныхКонфигурация. Используется для доступа к структуре метаданных конфигурации.
Доступность:
Сервер, толстый клиент, внешнее соединение.

Нужное подчеркнуть? :)
   Shutov
 
32 - 08.10.10 - 21:51
(31) Согласись, в этом задании это абсолютно не принципиально сейчас?
   Nikitvol
 
33 - 08.10.10 - 21:52
(23) задачу по бухгалтерии решил (раскрыл на 13 страниц, надеюсь этого хватит), но еще не отправлял. Вот сделаю "перегрузку документа", тогда отправлю.
(27) Спасибо :)
(28) А что это: управляемый и обычный режимы?
   ВлюбленныйРомео
 
34 - 08.10.10 - 21:54
хрусталев ето тот что в камеди клаю снимается ?
   Shutov
 
35 - 08.10.10 - 21:55
(33) Везет, по почте сдаешь задания. Я тоже исписал 10 страниц в свое время, приехал сдавать в офис, а мне их закрыли и заставили писать по памяти на чистом листе :)
Пожалуйста :) Обращайся.
Сейчас все стандартные конфигурации работают в обычном режиме, поэтому не заморачивайся на этом. (условно - управляемый режим нужен, если мы хотим к этой базе доступ через веб обеспечить напрямую).
   AlexNew
 
36 - 08.10.10 - 21:55
(30) Не понял, где что-то было некорректно, кроме постановки задачи и твоих ответов на вопросы?
   GenV
 
37 - 08.10.10 - 21:57
(32) Сейчас, судя по его информированности, нет. Но в общем отличия существенные.
(33) В управляемом режиме идет разделение вызовов на клиент и сервер. И весь интерфейс/формы по другому строятся.
   Shutov
 
38 - 08.10.10 - 21:58
(36) Смотри (16), написал, что сериализацию нельзя использовать.
   ВлюбленныйРомео
 
39 - 08.10.10 - 21:59
33 я тебе честно расскажукогда я пришел работать прогарммситом 1с мне платили за выполнение 1сных задач ...я примерно неделю пытался свернуть таблицу занчений по колонкам пришлось прочитать жкк) я б за бесплатно не согласился - не те деньги у программистов чтобы обучени етебе не оплачивалось, лучше идти менегером там перспективы есть
   Shutov
 
40 - 08.10.10 - 22:02
(39) Если ничего не изменилось, то выполнение таких учебных задач оплачивается в каком-то учебном размере.
Если же учишься на рабочих задачах с проекта, то они оплачиваются, но по ставке и времени работы опытного специалиста 1С.
   Nikitvol
 
41 - 08.10.10 - 22:03
(35) Вот жесть, а я бы и не подумал, что могут спросить по заданию.
(39) мне программировать по душе.
   AlexNew
 
42 - 08.10.10 - 22:04
(38) В условиях этого не было, а если бы к нам пришел чел, к-рый умеет это использовать, я думаю, что он бы получил определенные преференции. То, что люди не умеют этим пользоваться не умоляет значения механизма. Привет великам!!!
   ВлюбленныйРомео
 
43 - 08.10.10 - 22:04
41 дурак :(
   Nikitvol
 
44 - 08.10.10 - 22:05
(43)эт почему?
   AlexNew
 
45 - 08.10.10 - 22:06
(43) Главное, что он не одинок, в своем заблуждении:)
   Shutov
 
46 - 08.10.10 - 22:20
(42) Написал же в (8), что знаю это задание и эту компанию. Сам принимал такие же задания в этой компании у стажеров.
И если бы к нам пришел чел с сериализацией в обработке, то конечно бы ничего страшного не случилось, но он пошел бы переделывать тоже самое без сериализации.
(43) Это очередной тролль %) Или бухой программист 1С ;) Пятница же.
(44) Реально в Сиринте, незнаю как сейчас, но раньше можно было очень хорошие деньги поднимать, тем более для студента! По сравнению с другими 1С-франчайзи, которые действительно стажеров отправляла на ИТС (диски развозить) и прочую не интересную работу, здесь тебя грузили действительно рабочими задачами и всегда давали больше ответственности за то, что ты делаешь. Поэтому советую!
   Nikitvol
 
47 - 08.10.10 - 22:29
(46) Спасибо, пробиться бы еще туда :)
Я так понимаю ты сейчас и работаешь в Сиринте?
   Immortal
 
48 - 08.10.10 - 22:30
(46)гг..
ответственность как мотивация это немного смешно
   Shutov
 
49 - 08.10.10 - 22:36
(47) Это реально, если есть "голова на плечах".
Я уехал 2,5 года назад и работаю теперь в Москве. В Сиринте работал на проектах БФК, СПК, НГУ и др.
(48) Это круто, это реально тебя поднимает. Год работы в таком режиме и подъем в опыте на 5 лет!
Прихожу на собеседование в Москве, мне говорят - как так, вам 25, а вы - руководитель проектов?! У нас моложе 30-ти такую должность не занимают, потому что еще нет опыта.
   Nikitvol
 
50 - 08.10.10 - 22:39
(49) Получается ты в Новосибе учился?
   Shutov
 
51 - 08.10.10 - 22:41
(50) Да, СибГУТИ.
   Nikitvol
 
52 - 08.10.10 - 22:45
(51) Понятно, а я в СГГА на 4м щас.
   ice777
 
53 - 08.10.10 - 22:52
Походу, рекламюги начального уровня не отстают от журналюг )
   ice777
 
54 - 08.10.10 - 22:55
(48) естественно, еще бы смешно. За ответственность еще никто не снял квартиру.
   AlexNew
 
55 - 08.10.10 - 22:59
(46) А чем сериализация не угодила, или условия задачи задать конкретнее?
   Stalker1986
 
56 - 08.10.10 - 23:37
Люди, не спорьте! Задачка эта на перегрузку в Сиринте придумалась еще в бородатые годы. Я сам сдавал ее на 7.7, потом на 8.0. Смысл был такой как пишет Шутов - в изучении возможностей платформы на уровне метаданных. Причем пока напишешь эту обработку перелопатишь кучу литры, и реально начнешь втыкать че к чему. Понятно, что щас никто не будет писать выгрузку в текстовый файл, есть конвертация. Но на тот момент это был одним из часто используемых способов, поэтому и задачку учебную сделали в этом стиле.

А насчет эффективности работы ИТС-ником: ты тратишь свое время на тупую работу - изучение инсталляционного пакета 1С, дорогу от одного клиента к другому и т.д. вместо решения конкретных задач, где нужна смекалка, творческий подход, коммуникабельность, умение работы в команде, умение разбираться в незнакомой теме, предметной области. Хотите быстрого проф. роста - работайте задешево, но на проектах под руководством спецов. Не нужно питать иллюзий - пока человек не изучит УПП (именно УПП, потому что в ней наиболее полный пакет учетных блоков)вдоль и поперек на РЕАЛЬНЫХ задачах - он ламер, а не специалист 1С. И потому как ламеру ему положена маленькая зарплата. Большая зарплата у НЕ специалиста сразу может быть только там, где нет никаких перспектив (если ты конечно не гений). Поэтому обучение ПОЧТИ бесплатное - хочешь учись, не хочешь - не учись.
   ice777
 
57 - 08.10.10 - 23:45
(56) а если к спецу подкидывают кукушёнка, который нацелен только на кaръеру?
   Stalker1986
 
58 - 08.10.10 - 23:56
а в чем нацеленность на карьеру заключается? :) или вопрос в том, что будет с кукушенком, который собирает галочки об участии в проектах?
   Shutov
 
59 - 09.10.10 - 00:00
(55) Нужно чтобы стажер понял, что есть нюансы при выгрузке реквизитов сложных типов. Например, что у справочников бывают Владельцы и их тоже нужно правильно выгружать и пр.

(56) Да, ты реально прав.

(57) К спецу ставят перспективного стажера, который уже проверено - научился основам 1С и готов быстро получать новые знания и развиваться самостоятельно, с достаточно минимальным вмешательством ведущего специалиста или руководителя проекта.
   Immortal
 
60 - 09.10.10 - 02:55
(49)жираф большой, ему видней..
 
 Рекламное место пустует
   МастерВопросов
 
61 - 09.10.10 - 05:03
(15) +1
"простые приемы"- самый короткий путь узнать "а как это делается в 1С".
   AlexNew
 
62 - 09.10.10 - 05:21
(56) Какую лит-ру, а предметную область куда? Конфигуряторы...
   AndreyFAN
 
63 - 09.10.10 - 05:43
Шутов, тебе +! из Молдавии :-) в Пятницу!
   Shutov
 
64 - 11.10.10 - 04:18
(63) Спасибо! :)
   Nikitvol
 
65 - 11.10.10 - 04:20
У тебя 4 часа ночи, а ты не спишь! :)
   kuzma7126
 
66 - 12.10.10 - 13:40
Делаю аналогичное задание. Просьба сильно не пинать)
как я понял нужно это сделать без плана обмена
Проблема в следущем:

&НаКлиенте
Процедура Выгрузить(Команда)
    Запись = Новый ЗаписьXML;
    пвИмяФайла = пвИмяФайла;
    Запись.ОткрытьФайл(пвИмяФайла, "UTF-8");
    Запись.УстановитьСтроку();
    ЗаписатьXML(Запись, пвИмяФайла.ПолучитьОбъект());
    Возврат  //Колво=Метаданные.ОбщийРеквизитДокумента(); 
//*Для к=1 по Колво Цикл 
//    Сообщить("===============Общий реквизит документа=================="); //    Сообщить("Идентификатор:"+Метаданные.ОбщийРеквизитДокумента(к).Идентификатор); 
//    Сообщить("Синоним:"+Метаданные.ОбщийРеквизитДокумента(к).Синоним); //    Сообщить("Комментарий:"+Метаданные.ОбщийРеквизитДокумента(к).Комментарий); 
//   Сообщить("Тип:"+Метаданные.ОбщийРеквизитДокумента(к).Тип); 
 //  Сообщить("Вид:"+Метаданные.ОбщийРеквизитДокумента(к).Вид); 
//    Сообщить("Длина:"+Метаданные.ОбщийРеквизитДокумента(к).Длина); //    Сообщить("Точность:"+Метаданные.ОбщийРеквизитДокумента(к).Точность); 
//    Сообщить("НеОтрицательный:"+Метаданные.ОбщийРеквизитДокумента(к).НеОтрицательный); //    Сообщить("РазделятьТриады:"+Метаданные.ОбщийРеквизитДокумента(к).РазделятьТриады); 
//    Сообщить("Сортировка:"+Метаданные.ОбщийРеквизитДокумента(к).Сортировка); //КонецЦикла;     
    запись.Закрыть();
КонецПроцедуры

выдает ошибку {Форма.ПерегрузкаДокумента.Форма(38,28)}: Процедура не может возвращать значение
    запись.Закрыть(пвИмяФайла)<<?>>; (Проверка: Сервер)
{Форма.ПерегрузкаДокумента.Форма(38,28)}: Процедура не может возвращать значение
    запись.Закрыть(пвИмяФайла)<<?>>; (Проверка: Тонкий клиент)
   Nikitvol
 
67 - 12.10.10 - 15:24
(66) тоже в Сиринт устраиваешься?
   NcSteel
 
68 - 12.10.10 - 15:27
(66) Код один а ошибка из другой оперы ? приведи в соответствие

запись.Закрыть(пвИмяФайла) <> запись.Закрыть()
   kuzma7126
 
69 - 12.10.10 - 15:35
спасибо, разобрался.
Nikitvol, ага
   Nikitvol
 
70 - 12.10.10 - 15:44
(69) забавно :)
Я так вижу ты с 1С давно уже знаком?
   kuzma7126
 
71 - 12.10.10 - 15:50
нет. только начал. 4 дня изучаю
   Nikitvol
 
72 - 12.10.10 - 15:56
(71)И как? Близок к завершению задания?
Тебе так же, 2 задания дали (по бухгалтерии и 1с)?
   kuzma7126
 
73 - 12.10.10 - 16:06
да. первое сделал.отправил. Второе в процессе, но конец еще не близок (
   Nikitvol
 
74 - 12.10.10 - 16:08
(73)Какой объём по первому заданию получился? Ответ не прислали никакой?
   kuzma7126
 
75 - 12.10.10 - 16:11
Мб личку будем писать? хотя... её здесь нет)
   Nikitvol
 
76 - 12.10.10 - 16:17
(75) да, надо бы в личку :) пиши мне на почту, она у меня не скрыта должна быть.
Или другой вариант предложи :)
   kuzma7126
 
77 - 12.10.10 - 16:22
проверь почту
   Nikitvol
 
78 - 12.10.10 - 16:27
(77) WTF!! Дибильная почта, глючи, ниче не пришло :(
   kuzma7126
 
79 - 12.10.10 - 16:29
стучи в аську 4девять3 4четыре4 66три
   Nikitvol
 
80 - 12.10.10 - 16:32
Щас погоди.
скачаю, установлю, зарегюсь :)
   Nikitvol
 
81 - 12.10.10 - 17:12
(79) чето не могу я тебя найти :(
   kuzma7126
 
82 - 12.10.10 - 17:14
скажи свой номер. сам тебя найду
   Nikitvol
 
83 - 12.10.10 - 17:15
да вот как раз с номером я и запуталси :(
почта заканала!
   ILM
 
84 - 12.10.10 - 19:12
(0) Круто, но чоткие пацаны, используют иногда и хранилище значений )))
Получил объект, положил в хранилище и записал. А ещё можно и несколько строк в ТЗ сделать, а потом всю её в хранилище и в файл. Тогда и никаких XML не нужно)))
   jcage
 
85 - 12.10.10 - 19:22
Учись, студент:

Процедура Выгрузить()

Объект = СсылкаСФормы.ПолучитьОбъект();
ЗначениеВФайл(ПутьКФайлу, Объект);

КонецПроцедуры

Процедура Загрузить()

Объект = ЗначениеИзФайла(ПутьКФайлу);

Попытка
Объект.Записать();
Исключение
КонецПопытки

КонецПроцедуры
   Nikitvol
 
86 - 12.10.10 - 20:09
(85) спасибо конечно, но у нас в задании написано:

4.    При написании обработки не использовать функции «ЗначениеИзСтроки( )» и «ЗначениеВСтроку( )». Это условие дается для взятия формата выгрузки и загрузки под свой контроль.
5.    Не использовать функцию «Универсальные идентификаторы».


Вот еслиб мастер класс "Учись студент" без этих функций показали...  :)
   jcage
 
87 - 12.10.10 - 20:26
4.    При написании обработки не использовать функции «ЗначениеИзСтроки( )» и «ЗначениеВСтроку( )». Это условие дается для взятия формата выгрузки и загрузки под свой контроль.

а где я использовал эти функции? Я использовал "ЗначениеВФайл" - это другое..
   Nikitvol
 
88 - 12.10.10 - 20:30
(87) да...   но они так похожи :)
   Nikitvol
 
89 - 12.10.10 - 20:33
(87) А как на счет вот этого пункта:

3.    При написании обработки необходимо использовать элемент языка «Метаданные. …». Это делается для универсализации программного кода.
   Nikitvol
 
90 - 12.10.10 - 20:34
+
И этого:
2.    По кнопке «Выгрузить» информация, содержащая в выбранном документе, выгружается в указанный файл. Информация должна быть исчерпывающей, то есть выгружаться должна такая информация, чтобы при нажатии кнопки «Загрузить» в базе создавалась бы копия исходного документа (за исключением номера, так как номера документов в системе уникальные).
   jcage
 
91 - 12.10.10 - 20:35
Процедура Выгрузить()

Если Не Метаданные.Содержит(Объект.Метаданные()) Тогда
Предупреждение("Это не документ!");
Возврат;
КонецЕсли;

Объект = СсылкаСФормы.ПолучитьОбъект();
ЗначениеВФайл(ПутьКФайлу, Объект);

КонецПроцедуры

Процедура Загрузить()

Объект = ЗначениеИзФайла(ПутьКФайлу);

Объект.УстановитьНовыйНомер();
Попытка
Объект.Записать();
Исключение
КонецПопытки

КонецПроцедуры


Все условия соблюдены.
   Nikitvol
 
92 - 12.10.10 - 20:37
т.е. и загрузится с новым номером? :)
   Nikitvol
 
93 - 12.10.10 - 20:42
(91) Спасибо конечно. Возьму на заметку.
Только вот эта фраза:
"Информация должна быть исчерпывающей, то есть выгружаться должна такая информация..."
Звучит так, как будто нужно перебирать все элементы и записывать те которые нужно.
   jcage
 
94 - 12.10.10 - 20:47
Через СериализаторXDTO сделай. Пример в ветке был.
   Nikitvol
 
95 - 12.10.10 - 20:50
в ветке и нельзя говарили...


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.