Вход | Регистрация
 

Таблица значений: получить/установить значение колонки по номеру строки

Таблица значений: получить/установить значение колонки по номеру строки
Я
   mirrr
 
13.09.10 - 09:32
Подскажите, какие методы использовать в 8.2, аналогичные методам в 7.7:

ТЗ.ПолучитьЗначение(НомерСтроки, НомерКолонки) - получить значение колонки по номеру строки.

ТЗ.УстановитьЗначение(НомерСтроки,НомерКолонки,Значение) -установить значение в колонке по номеру строки.
   butterbean
 
1 - 13.09.10 - 09:35
ТЗ[НомерСтроки][НомерКолонки]
   mirrr
 
2 - 13.09.10 - 09:39
(1) после "ТЗ" сразу "[" ?
   luckyluke
 
3 - 13.09.10 - 09:41
(2) ну если не нравится, то поставь пробел после ТЗ, а потом СРАЗУ "["!
   mirrr
 
4 - 13.09.10 - 09:43
так?
ТЗ(НомерСтроки, НомерКолонки)
   butterbean
 
5 - 13.09.10 - 09:44
(4) издеваешься?
   Ненавижу 1С
 
6 - 13.09.10 - 09:45
(4) ты скобки какие поставило?
   Aprobator
 
7 - 13.09.10 - 09:45
(5) не все путем. Просто видно пробел + [ = (
   Defender aka LINN
 
8 - 13.09.10 - 09:47
(1) Попробуй свой код на ТЗ из одной строки и/или колонки.
   butterbean
 
9 - 13.09.10 - 09:48
(8) на нули намекаешь?
   Aprobator
 
10 - 13.09.10 - 09:49
(9) намекает, что корректнее писать ИндексСтроки и ИндексКолонки.
   Defender aka LINN
 
11 - 13.09.10 - 09:49
(9) Типа того
   mirrr
 
12 - 13.09.10 - 10:01
подскажите ещё, как получить текущую строку в ТЗ (вместо ИндексСтроки должна быть текущая строка таблицы) 
ТЗ[ИндексСтроки][ИндексКолонки]
   luckyluke
 
13 - 13.09.10 - 10:03
(12) справку отобрали? или религия не позволяет читать синтаксис помощник?
ИндексТекСтроки = ТЗ.Индекс(ТекСтрокаТЗ)
   Defender aka LINN
 
14 - 13.09.10 - 10:08
(12) У ТЗ не бывает текущей строки.
   luckyluke
 
15 - 13.09.10 - 10:12
(14) настроение с утра плохое? Ну какая разница как он называет строку, которую он собирается обрабатывать? То ли текущя, то ли моястрока, то ли СтрокаТЗКоторуюЯСейчасОбработаю...
   Ненавижу 1С
 
16 - 13.09.10 - 10:13
(15) не у ТЗ текущей строки, у табличного поля есть, но может быть два ТП к одной ТЗ
   Aprobator
 
17 - 13.09.10 - 10:13
(15) нормальное у него настроение ). Просто кто-то не проснулся с утра. ТекущаяСтрока у ТабличногоПоля.
   Defender aka LINN
 
18 - 13.09.10 - 10:14
(15) Ну, раз "какая разница", то давай ТЗ называть документом, документ - движением, а регистр - таблицей. Еще можно макет называть текстом. Какая разница?
   mirrr
 
19 - 13.09.10 - 10:16
(13) переменную "ТекСтрокаТЗ" надо сначала определить. Вот я про это и спрашивал, как в нее получить текущую строку (добавляю в ТЗ строки, и текущая - последняя добавленная)
   Aprobator
 
20 - 13.09.10 - 10:17
(19) мдя. Как получить номер последней строки в ТЗ? СП вооще читать не хотим?
   luckyluke
 
21 - 13.09.10 - 10:17
(18) Т.е. вот так писать плохо: "Для ТекущаяСтрокаТЗ Из ТЗ Цикл"? Потому что у ТЗ не может быть текущей строки?
   mirrr
 
22 - 13.09.10 - 10:19
(19) т.к. индекс начинается с нуля, то:
текиндексстроки=тз.Количество()-1; ?
   Ненавижу 1С
 
23 - 13.09.10 - 10:21
надоело:

ТекущаяСтрока = ЭлементыФормы.ТЗ.ТекущаяСтрока;
   Aprobator
 
24 - 13.09.10 - 10:22
(22) уже лучше.
   73
 
25 - 13.09.10 - 10:24
(19) [(добавляю в ТЗ строки, и текущая - последняя добавленная)]

Посмотри что возвращает метод Добавить(). Зачем искать, то, что уже есть?
   Defender aka LINN
 
26 - 13.09.10 - 10:25
(21) А вот такое тебе тогда как:
Для Каждого ТекущаяСтрока из ТЗ Цикл
    Для Каждого ЕщеБолееТекущаяСтрока из ТЗ Цикл

    КонецЦикла;
КонецЦикла;

Сколько текущих строк вы видите? :)
   luckyluke
 
27 - 13.09.10 - 10:32
(26) одну текущую, и одну еще более текущую о.О
можно еще так:
Для Каждого строка из ТЗ Цикл
    Для Каждого строчка из ТЗ Цикл
         Для Каждого строчечка из ТЗ Цикл

         КонецЦикла;
    КонецЦикла;
КонецЦикла;
:)
   mirrr
 
28 - 13.09.10 - 11:02
(20) как раз этого: "ТЗ[НомерСтроки][НомерКолонки]" в СП нет.

(13) можно как-то еще получить текстроку, кроме как обходом строк          
"Для ТекСтрокаТЗ Из ТЗ Цикл" , чтобы потом получить индекс этой строки?
   73
 
29 - 13.09.10 - 11:04
(28) А метод Добавить() есть в СП?
   kokamoonga
 
30 - 13.09.10 - 11:06
(28)

 НоваяСтрокаТЗ = ТвояТЗ.Добавить();//это и есть твоя текущая строка
 
 Рекламное место пустует
   73
 
31 - 13.09.10 - 11:07
(29)+ Как раз про [] есть. Только нужно из 2х мест собрать.

ТаблицаЗначений (ValueTable)
Элементы коллекции:
СтрокаТаблицыЗначений
Для объекта доступен обход коллекции посредством оператора Для каждого … Из … Цикл. При обходе выбираются элементы коллекции.
Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс (нумерация с 0) строки.


..........

КоллекцияКолонокТаблицыЗначений (ValueTableColumnCollection)
Элементы коллекции:
КолонкаТаблицыЗначений
Для объекта доступен обход коллекции посредством оператора Для каждого … Из … Цикл. При обходе выбираются элементы коллекции.
Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс (нумерация с 0) элемента.
   mirrr
 
32 - 13.09.10 - 11:10
(29) пишу:
новаястрока=тз.добавить();
новаястрока.колонка1=значение1;
новаястрока.колонка2=значение2;
так получилось:
тз[тз.Индекс(новаястрока)][ИмяКолонки]=значение3;
   mirrr
 
33 - 13.09.10 - 11:11
подскажите, где скачать скомпилированный хтмл-файл с описанием встроенного языка 8.2 или хоть 8.1
   73
 
34 - 13.09.10 - 11:11
(32) А почему не так? :

новаястрока[ИмяКолонки]=значение3
   73
 
35 - 13.09.10 - 11:12
(33) В справку загляни.
   mirrr
 
36 - 13.09.10 - 11:16
(31) "Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс (нумерация с 0) элемента."
Если надо обратится не к элементу коллекции (строке таблице), а к ячейке (строка/столбец), то догадываться поставить 2 пары скобок для строки и колонки надо самому?
   73
 
37 - 13.09.10 - 11:18
(36)
Можно не догадываться, а в 2 строки записать:

СтрокаТЗ = ТЗ[ИндексСтроки];
ЯчейкаТЗ = СтрокаТЗ[ИндексКолонки];
   mirrr
 
38 - 13.09.10 - 11:24
у меня в СП: "Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс строки (нумерация с 0)."
Что можно передать туда еще индекс колонки, понять можно не сразу.
   73
 
39 - 13.09.10 - 11:25
(38) Ну получил строку.
Дальше читай в СП про строку:

СтрокаТаблицыЗначений (ValueTableRow)
Элементы коллекции:
Произвольный
Для объекта доступен обход коллекции посредством оператора Для каждого … Из … Цикл. При обходе выбираются значения в колонке данной строки.
Возможно обращение к значению колонки данной строки посредством оператора [...]. В качестве аргумента передается индекс (нумерация с 0) колонки.
   mirrr
 
40 - 13.09.10 - 11:32
да, недосмотрел.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.