Вход | Регистрация
 

Конвертация данных. Помогите разобраться.

Конвертация данных. Помогите разобраться.
Я
   Bor_ka
 
09.04.10 - 22:15
Читаю статью "v8: Как правильно пользоваться переносом остатков 7.7 - 8.0 с помощью КД 2.0". Не понимаю пункт 2.2, помогите разобраться.
 
 
   Bor_ka
 
1 - 09.04.10 - 22:15
   Bor_ka
 
2 - 09.04.10 - 23:00
Поделитесь опытом, кто читал эту статью и пробовал второй способ конвертации (через таблицку значений / список значений)
   AlexNew
 
3 - 09.04.10 - 23:40
Там есть еще и ВыгрузитьПоПравилу(), если хочешь в док-т. Что ты хочешь получить?
   Bor_ka
 
4 - 09.04.10 - 23:50
Перенести остатки из 77 Тис 9.2 в 8.1 КомплекснаяАвтоматизация. Мой первы вопрос решился тем, что нужно при выгрузке структуры метаданных из 8.1 (база приемник) убрать все галочки (обработка MD81Exp.epf)
   Bor_ka
 
5 - 09.04.10 - 23:52
Теперь при попытке выгрузить данные из 77 ошибка:
Начало выгрузки:   09.04.10 22:37:27
Начало обработки правила выгрузки данных:  ОстаткиТоваров
ПВД_ПередОбработкойПравила_ОстаткиТоваров<<?>>(ИмяПКО, Правило, ИсходящиеДанные, ВыборкаДанных)
Функция не обнаружена (ПВД_ПередОбработкойПравила_ОстаткиТоваров)
Выгружено объектов:   0
   AlexNew
 
6 - 09.04.10 - 23:58
А ты в 7.7 код затаскивал? в ert?
   Bor_ka
 
7 - 10.04.10 - 00:00
Нужно при сохранении правил обмена (в конфигурации Конвертация данных) устанавливать флажек "Выгружать модуль обработки выгрузки данных для платформы 7.7" 

Потом, этим модулем заменить модуль обработки v77Exp.ert

Решилось!!! (Спасибо редактору статьи Defender aka LINN и AlexNew)
   AlexNew
 
8 - 10.04.10 - 00:05
О сколько нам открытий чудных:)
   Bor_ka
 
9 - 14.04.10 - 22:17
В продолжении темы есть вопрос: "Какая должна быть структура таблицы значений если мне нужно в результате получить несколько документов?" (например создввать документ "Оприходование товаров" по каждому складу), Пробовал добавлять несколько строк, но при загрузке обрабатывается только первая.
   Maniac
 
10 - 14.04.10 - 22:24
(9) любую структуру ТЗ можно обработать как угодно.
   Maniac
 
11 - 14.04.10 - 22:24
(10) привет кстати))
   Maniac
 
12 - 14.04.10 - 22:24
11 к (9)
   Lucky-1
 
13 - 14.04.10 - 22:26
Вылаживай код, подправим
   Bor_ka
 
14 - 14.04.10 - 22:48
(10) Привет :) Женя ты?
   Bor_ka
 
15 - 14.04.10 - 22:49
ВыборкаДанных = СоздатьОбъект("ТаблицаЗначений");
ВыборкаДанных.НоваяКолонка("Дата");
ВыборкаДанных.НоваяКолонка("Номер");
ВыборкаДанных.НоваяКолонка("Организация");
ВыборкаДанных.НоваяКолонка("Склад");
ВыборкаДанных.НоваяКолонка("Товары");

Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса = 
"//{{ЗАПРОС(Остатки)
 
|Период с ДатаОкончания по ДатаОкончания;
|Фирма                 = Регистр.ПартииНаличие.Фирма;
|Номенклатура         = Регистр.ПартииНаличие.Номенклатура;
|Склад                 = Регистр.ПартииНаличие.Склад;
|Количество         = Регистр.ПартииНаличие.Количество;
|ЦенаПрод             = Регистр.ПартииНаличие.ЦенаПрод;
|Функция Остаток     = КонОст(Количество);
|Группировка Склад;
|Группировка Номенклатура без групп;
|//}}ЗАПРОС
 
;

Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Отказ = 1;
    Возврат;//Отказ; //В 8.0/8.1 Возврат использовать нельзя!
 
КонецЕсли;
Сч = 1;
Пока Запрос.Группировка(1) = 1 Цикл
    ВыборкаДанных.НоваяСтрока();
    ВыборкаДанных.Дата = ДатаОкончания;//ДатаОкончания - реквизит обработки "Выгрузка данных"
 
    ВыборкаДанных.Номер = "0000000000"+Сч;
    ВыборкаДанных.Организация = Запрос.Фирма;
    ВыборкаДанных.Склад = Запрос.Склад;
    ВыборкаДанных.Товары = СоздатьОбъект("ТаблицаЗначений");    
    
    Товары = ВыборкаДанных.Товары;
    Товары.НоваяКолонка("Номенклатура");
    Товары.НоваяКолонка("ЕдиницаИзмерения");
    Товары.НоваяКолонка("Коэффициент");
    Товары.НоваяКолонка("Количество");
    Товары.НоваяКолонка("Качество");
    Товары.НоваяКолонка("СтатусПартии");
    Товары.НоваяКолонка("Цена");
    Товары.НоваяКолонка("Сумма");
    Пока Запрос.Группировка(2) = 1 Цикл
       //Для перечислений достаточно указать имя значения, обработка загрузки вставит нужное значение
 
       //1/0 конвертируются в булевские Истина/Ложь
 
        БазоваяЕдиница = Запрос.Номенклатура.БазоваяЕдиница;
        Товары.НоваяСтрока();
        Товары.Номенклатура        = Запрос.Номенклатура;
        Товары.ЕдиницаИзмерения    = ?(БазоваяЕдиница.Выбран() = 1, БазоваяЕдиница, "шт."); 
        Товары.Коэффициент         = ?(БазоваяЕдиница.Выбран() = 1, БазоваяЕдиница.Коэффициент, "1");
        Товары.Количество          = Запрос.Остаток;
        Товары.Качество            = "Новый";
        Товары.СтатусПартии        = "Купленный";
        Товары.Цена                = Запрос.ЦенаПрод;
        Товары.Сумма                = Запрос.Остаток*Запрос.ЦенаПрод;
    КонецЦикла; 
    Сч = сч+1;
КонецЦикла;
   Bor_ka
 
16 - 14.04.10 - 22:54
Я так понимаю, нужно создать еще одну ТЗ более высого уровня, но какие колонки должны быть?
   Bor_ka
 
17 - 14.04.10 - 23:04
Есть ошибки в модуле:
Регистр.ПартииНаличие -- Регистр.ОстаткиТМЦ
Возврат;//Отказ -- Возврат Отказ;
   Lucky-1
 
18 - 15.04.10 - 02:02
А где "ВыгрузитьПоПравилу()";
   Lucky-1
 
19 - 15.04.10 - 02:05
после:
   Сч = сч+1;
Добавь строку:        
    ВыгрузитьПоПравилу(,, ВходящиеДанные,, "ОприходованиеТоваров");
   Lucky-1
 
20 - 15.04.10 - 02:08
+(19)    где ВходящиеДанные - СписокЗначений,    
    ОприходованиеТоваровОстатки - существующее правило
   Bor_ka
 
21 - 15.04.10 - 14:00
Сделал:
Сч = сч+1;             
ВыгрузитьПоПравилу(,, ВыборкаДанных,, "ОприходованиеТоваров");

Получил:
Ошибка выбора объектов коллекции
Ошибка выбора объектов коллекции
Ошибка выбора объектов коллекции
Ошибка выбора объектов коллекции

 // 4 склада
   Живой Ископаемый
22 - 15.04.10 - 14:05
(0)А где ты читаешь эту статью?
   Живой Ископаемый
23 - 15.04.10 - 14:24
вот эту?
Книга знаний: Как правильно пользоваться переносом остатков 7.7 - 8.0 с помощью КД 2.0

Статья удалена.        Автор статьи: Maniac | Редакторы: Defender aka LINN
Последняя редакция №4 от 10.04.10 | История
URL: Книга знаний: Как правильно пользоваться переносом остатков 7.7 - 8.0 с помощью КД 2.0    

Ключевые слова: Конвертация данных, КД, Конвертация, Перенос остатков, Обмен данными
   Рэйв
 
24 - 15.04.10 - 15:13
(1)Почитай лучше
В.Э.Бояркин, А.И.Филатов
"1С.Предприятие 8.
Конвертация данных.Обмен данными между прикладными решениями"
   Bor_ka
 
25 - 15.04.10 - 17:21
(24) Смотри историю... там есть сохраненные предидущие версии
   Bor_ka
 
26 - 15.04.10 - 17:32
(24) Поделись ссылкой если имеешь. Предидущее сообщение адресовано на (23)


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.