Вход | Регистрация
 

Обнаружил перл в глобальном модуле ЗИК 263

Обнаружил перл в глобальном модуле ЗИК 263
Я
   Doomer
 
12.03.06 - 12:47
Обнаружил перл.
....
ИначеЕсли (ОписательХО=3)  Тогда // прочие доходы
   ЧтоЗаСчет=глХарактеристикаСчета(ШаблонПроводки.СчетДебета);
   Если (ЧтоЗаСчет<>5) и (ЧтоЗаСчет<>3)  Тогда
       Возврат 0
   КонецЕсли;
ИначеЕсли (ОписательХО=4) или (ОписательХО=9) Тогда
// больничные листы Дт 69 Кт 70.1
   Если глХарактеристикаСчета(ШаблонПроводки.СчетКредита)<>1 Тогда
       Возврат 0
   КонецЕсли;
     Если (глХарактеристикаСчета(ШаблонПроводки.СчетДебета)<>2) и (глХарактеристикаСчета(ШаблонПроводки.СчетДебета)<>9) Тогда
       Возврат 0
   КонецЕсли;
....

Функция ПроверкаХозоперации. Во всей функции идет проверка глХарактеристикаСчета(ШаблонПроводки.СчетДебета) или
глХарактеристикаСчета(ШаблонПроводки.СчетКредита)
 
 Партнерская программа EFSOL Oblako
   ШтушаКутуша
 
1 - 12.03.06 - 12:53
(0) вот из-за этого "пёрла" и прут проблемки,то что раньше работало в пред.
конфах,в 263 работает иначе и я не знаю зачем эти изменения были внесены

Список тем форума
 
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.