Вход | Регистрация
 

Помогите в ЗиК !

Ø
Помогите в ЗиК !
Я
   Бывалый эсник
16.11.05 - 18:25
ВР "Сохраняемый заработок на время трудоустройства". Период с 10.10 по 15.11. В свод октябрьская часть попадает на 26 (правильно), а ноябрьская - на 97. ГБ хочет видеть всю сумму на 26, без разделения периодов и учета РБП. Как сделать, может добавить/усключить какую-то группы расчетов по данному ВР?
Спасибо
 
 Партнерская программа EFSOL Oblako
   NS
1 - 16.11.05 - 18:28
Раздерибанить гл. модуль (поменять одну строку)
Но оно надо?
   Бывалый эсник
2 - 16.11.05 - 18:30
ага, вот бы еще подсказал где :)
когда-то давненько решал такую проблему и без переписывания Гл. модуля. Вроде как-раз группами разрулил, не помню уже..
   Бывалый эсник
3 - 16.11.05 - 18:34
мужики, горю...
   NS
4 - 16.11.05 - 18:39
  ПодменятьСчетДебетаНаСчетБудущихПериодов = 0;
      Если (ТипКонфигурации="Бюджет") или (ТипКонфигурации = "ПБОЮЛ") Тогда
        // не подменять счета дебета
      ИначеЕсли (ДатаНачала > КонецПериода) и ((ВР.ВходитВГруппу(ГруппаРасчетов.ВсеУдержания)=0)и (ВР.ВходитВГруппу(ГруппаРасчетов.ВозвратыНДФЛ) = 0)) Тогда
        Если (СчетБудущихПериодов.Выбран() = 0) Тогда
          Хорошо=0;
          Продолжить;
        Иначе
          ПодменятьСчетДебетаНаСчетБудущихПериодов = 1;
        КонецЕсли;
      КонецЕсли;// найдешь этот кусок?
   NS
5 - 16.11.05 - 18:44
Счета.ВыбратьЭлементы();
    Пока Счета.ПолучитьЭлемент() = 1 Цикл
      Если глХарактеристикаСчета(Счета.Код) = 6 Тогда
        СчетБудущихПериодов = Счета.ТекущийЭлемент();
      КонецЕсли;
    КонецЦикла;// Либо вот эта фигулина, сделать чтоб он был не выбран (можно редактированием плана счетов)
   Бывалый эсник
6 - 16.11.05 - 18:50
Спасибо NS.
   Бывалый эсник
7 - 16.11.05 - 19:21
NS, подскажи еще, пожалуйста.
не понятно откуда берется проводка на сумму 738 по счету 97
начисления, удержания, ЕСН сходятся, дополнительная проводка только 69.11. Начислений прошлого периода нет..
Счет и Оплата труда ЕСН и дополнительные проводки
код аналит. учета 70 69.2.1 69.2.3 69.2.2 69.3.2 69.1 69.3.1 69.11 97
"26
26.20-Оплата труда
АУП" 12 178,30 0,00 0,00 0,00 0,00 0,00 0,00 0,00 738,00
"26
26.30-ЕСН с оплаты труда
АУП" 0,00 731,00 0,00 0,00 244,00 390,00 97,00 0,00 0,00
"26
Прочие налоги и отчисления
АУП" 0,00 0,00 487,00 1 218,00 0,00 0,00 0,00 146,00 0,00
ИТОГО: 12 178,30 731,00 487,00 1 218,00 244,00 390,00 97,00 146,00 738,00
   Бывалый эсник
8 - 16.11.05 - 19:26
26-Оплата труда - 70 = 12178,3 руб
26-ЕСН с оплаты труда - (69.2.1 / 69.1 / 69.3.1 / 69.3.2) = 1462 руб
26-Прочие налоги и отчисления - (69.2.2 / 69.2.3 / 69.11) = 1851 руб
все сходится по налогам
но есть запись по строке:
26-Оплата труда  -  97 =  738 руб (откуда???)
   NS
9 - 16.11.05 - 19:27
// суммы с кредита 97 счета, начисленные в предыдущих периодах
  //**//
  Если  (СчетБудущихПериодов.Выбран() = 1) и (Конфигурация <> "ПБОЮЛ") и (ТипКонфигурации <> "Бюджет") и (АналитикуПоРБПсобиратьПоНовому = 0) Тогда
  
    // табличка собранных данных по ЕСН по сотрудникам за разл. года:
    ТаблицаСоответствияДанныхЕСН = СоздатьОбъект("ТаблицаЗначений");
    ТаблицаСоответствияДанныхЕСН.НоваяКолонка("ДатаСбораЕСН","Дата");
    ТаблицаСоответствияДанныхЕСН.НоваяКолонка("Сотрудник","Справочник.Сотрудники");
    ТаблицаСоответствияДанныхЕСН.НоваяКолонка("ТаблицаЕСН","ТаблицаЗначений"); // Данные ЕСН по сотруднику за данный год
    
    НачалоТекущегоМесяца = НачалоМесяца;
    ТекущийГод = ДатаГод(ДатаАктуальности);// начиная с этого куска идет, но проводка по кредиту 97-го может быть только в том случае, если период регистрации начисления меньше раньше периода действия. (проводка пойдет в периоде действия)
   NS
10 - 16.11.05 - 19:33
Процедура глЗаполнитьТаблицуНалогов(ТаблицаУчетаНалоговННП,ШаблонНУ,ВидНачисления,Сумма,ДатаОкончания,
                  ЗначениеВТаблицуФСС_НС,СтавкаВТаблицуФСС_НС,ЗначениеВТаблицуЕСН_ФБ,СтавкаВТаблицуЕСН_ФБ,
                  ЗначениеВТаблицуПФРСтраховаяЧасть,СтавкаВТаблицуПФРСтраховаяЧасть,
                  ЗначениеВТаблицуПФРНакопительнаяЧасть,СтавкаВТаблицуПФРНакопительнаяЧасть,
                  АналитикуПоРБПсобиратьПоНовому,ТаблицаУчетаНалоговННП_дляРБП,ВидНалога)
  
  ТаблицаУчетаНалоговННП.ШаблонРБП = ШаблонНУ;//это шаблон от базы!
// вот еще кусок...
   Бывалый эсник
11 - 16.11.05 - 19:33
как такое возможно, ЕСН начислен пропорционально начислению, откуда он взялся?
   NS
12 - 16.11.05 - 19:36
Функция глПроводкиЗаПериод(ДатаАктуальности,ОбобщенныйСотрудник,ТаблицаКорреспонденций,ТаблицаУчетаЗарплатыННП,ТаблицаУчетаНалоговННП,Форма = "", СписокСотрудниковДляСторноПарам = "", ДоходыВычетыНалогиСотрудниковПарам = "", ДоходыВычетыНалогиСотрудниковНДФЛПарам = "",АналитикуПоРБПсобиратьПоНовому = 0) Экспорт	
  
  
  // далее будем учитывать, наличие внутренних совместителей
  //это список содержит только Основные элемены, его используем для сбора данных по ЕСН
  Сотрудники = СоздатьОбъект("СписокЗначений");// вот еще один....
Наверно лучше сделать
АналитикуПоРБПсобиратьПоНовому = 1;// после объявления процедур
   NS
13 - 16.11.05 - 19:38
Извиняюсь!!! =0!!!
АналитикуПоРБПсобиратьПоНовому = 0;
   Бывалый эсник
14 - 16.11.05 - 19:44
дык и так 0 передается в функции глпроводкизапериод()?
или я не догоняю что-то...:(
   NS
15 - 16.11.05 - 19:47
(14) А ты счетБудущихПериодов очистил?
Вроде да, ноль.
   Бывалый эсник
16 - 16.11.05 - 19:47
самое интересное в ТЗ ТаблицаУчетаНалоговННП есть записи с периодом регистрации сентябрь, но база нулевая по ним и суммы налогов соответственно тоже 0, ноября нет вообще
   Бывалый эсник
17 - 16.11.05 - 19:53
Все, NS, благодарю. Вопрос решился комметом одной строки
ВыделятьСчетБудущихПериодов = 1
   NS
18 - 16.11.05 - 19:56
Точно, помнил же что только одну строку нужно убрать, даже на мисте писал - в архивах должно быть. Но уже подзабыл...
 Ну не требует никто 97 убирать.
   NS
19 - 16.11.05 - 19:58
Только это вроде на старых релизах было...
   Гена
20 - 16.11.05 - 20:08
(17) нельзя так делать - отпуск не будет начисляться на 97... неправильно будет рассчитан налог на прибыль и нарушен бухучёт, что приведёт к штрафным сануциям.
а по поводу (0): грубейшая ошибка бухгалтера - НЕЛЬЗЯ начислять сохраняемый заработок на время трудоустройства БУДУЩИМ периодом (в октябре за ноябрь)... эта компенсация ВСЕГДА начисляется постфактум = пройдёт ДВА месяца с даты увольнения - начислим ОДИН месяц компенсации по заявлению и отсутствии записи в трудовой книжке...
сделайте начисление в ТП: ноябрь - не будет и 97 счёта... а курочить модуль не надо.
   NS
21 - 16.11.05 - 20:10
(20) По практике знаю - некоторых бухов просто не переубедить. Правда последние... года три - мне это удается всегда. (во всяком случае по поводу 97-го)
   Гена
22 - 16.11.05 - 20:22
(21) да пусть обжигаются на 97-ом... здесь я прифигел от начисления компенсации БУДУЩИМ периодом... ведь сотр может спокойно получить бабки и устроиться на работу, скажем, на следуюший день - а (0) же на расходы возьмёт НЕзаконно начисленные деньги... Как минусовать неотработанный отпуск, так аж из кожи лезут чтоб сторнировать налоги, а здесь - на тебе:
БУДУЩАЯ компенсация...
полный финиш!
   Гена
23 - 16.11.05 - 20:54
(0) откуда взялся "Период с 10.10 по 15.11"???
почему он БОЛЬШЕ месяца???
какая дата увольнения?


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.